Sketchup 2018 hangs and goes to not responding when copying interior model objects into another model, which file size is 170Mb

advice

#1

Sketchup 2018 hangs and goes to not responding forever when copying interior model objects to my another model, which file size is 170MB. Followed is my system specs.

Dell WS 5820, Xeon CPU3.7Ghz, 128 GB ram / 11gb GPU nvidia GTX 1080Ti

Interior File size -87MB
another Model which is to be merged with interior file 175MB.
Could someone advise and help me out on above Please?


#2

Did you try with Import instead of copy/paste in place?


#3

@Mihai, Thanks for your reply.
I have tried import also, didn’t work. SU goes to not responding for ever even with import.


#4

With copy one element/group at a time, not everything at once?


#5

yes, with copy one element could be copied. all elements at once could not copy.


#6

How long is “forever” when SketchUp is not responding? I’d give it at least a few minutes before getting worried that its in an infinite loop or hung.


#7

I left an hour time to be respond sketch up from copy elements from another file, it was not responding., so I dids force close the software


#8

OK, good to know - an hour is plenty (unless the computer was paging or swapping its memory to death).


#9

Those are relatively large model files that could potentially contain millions of edges and faces. How well structured are they, that is, are all their edges and faces captured inside groups or components, or are many of them “loose” in the model? If there are a lot of loose edges and faces, SketchUp has to merge all of them during the import or copy and that could take a long time. On the other hand, if there are a lot of components it can take a long time to create the thumbnail images for the component browser.

Either way, given your pretty massive computer an hour seems like a long time.

Boy! With 128GB of RAM I’d really hope it isn’t paging or swapping due to SketchUp! But that raises the question: what else is running at the same time? If you have some other memory hog also live, it could be that even that vast memory is being overbooked. Have a look at the task manager while SketchUp is hung to check on this possibility.


#10

Shame on me, I did not check the Original Poster’s profile before posting my reply. 128GB of RAM is very generous and something to be envied! :slight_smile:


#11

@slbaumgartner, thanks for your reply. I had known from the end user, that the Interior model was imported from the Revit, Could it be caused to create this issue? Does Sketchup allow to copy the components / elements which has been imported from Revit?


#12

You may wish to left it longer. I copy/paste +400 MB models with no problems. Take a very long time +1 hours!


#13

May I know, what was the system configuration used by you for copy/paste +400 MB models in +1 hours?

And how would I know whether it is copying? and there is no copy progress bar to be determined the time.


#14

You could monitor the SketchUp process via Task Manager and see if it steadily consumes CPU. If not, then the process is probably hung and you might as well terminate it. If it is consuming CPU, hopefully it is not stuck in an “infinite loop” but instead is actually making progress toward completion.


#15

Sorry, I have no experience with Revit import. Perhaps someone who has tried it will chime in…


#16

Yes, BUT they all have the same origin and are seen as unique by SU…

before doing anything else they really need converting into SU components, if they have identical geometry, which is not an easy task…

the SU importer does not do this for you, but I believe there are extensions that will…

I wrote my own but it’s to slow for general release…

john


#17

I7-4790K with 16 GB, its a lot faster now on my new rig a I9-9900K with 32 GB. I usually go and start watching a movie.

I copy and paste my whole model (about 400 MB) to a new file and save it and for some reason it make the file smaller by about 100 MB :slight_smile:


#18

Did you purge unused from the whole model file? Typically a large change in file size is because the model had substantial amounts of unused content, such as components with no instances or unused textures.