Sketchup 2018 Bug or Feature


#1

I’m unsure if the following are new features or bugs. To me they feel like bugs;

What happened to the Shortcut Keys in 2018? Totally killed my efficiency with the use of this software.

Paint Bucket? It doesn’t work the way it used to: I.E. if I color a face and then select another face of the model to color a different color, when I select a new color on the wheel it changes the previously selected face. Now how is that supposed to be helpful?

Don’t mind the new changes, but the hotkeys (shortcut keys) have got to get turned back on. Until then I’ll do my best to figure how this new version works. I’ve been using SketchUp since 2009, just so you have an idea of how long I’ve used the shortcut keys and paint bucket. This update was the 1st extreme disappointment I have experienced with SketchUp. What happened? Did you guys hire the developers that Microsoft fired or something?


#2

It sounds to me as if you didn’t install SketchUp 2018 correctly. When you install it, you must right click on the installer file and choose Run as administrator. Any other method will result in incorrect installation and the things you describe can happen. A brief search of this forum would turn up those same problems and the fix has been to correctly install SketchUp.


#3

Good Morning Dave, I apologize in advance if you’re in a different time zone. If I recall correctly, when I opened the installer windows UAC prompted “Do you want to allow this app to make changes to this device?” & I clicked the “Yes” button; therefore I’m sure that the installer had administrative permissions to make the necessary changes to the system based on the way UAC functions.
There might be a conflicting bug in the SketchUp installer which requires this right click and run as administrator just to get the same UAC prompt you get just by simply double clicking it :wink:
I’ll let you know how it goes Dave. Thanks for the quick reply.


#4

I’ll repeat. If you didn’t right click on the installer and choose run as administrator, you did not install SketchUp correctly.

Close SketchUp and install it correctly. Select the Repair option when it presents itself.


#5

You Don’t have to repeat yourself, I read it correctly the 1st time. Did you not read in the last sentence, “I’ll let you know how it goes”, so again Dave, I’ll keep you posted after I’m done re-installing it.


#6

I did as you “requested” & still no shortcut keys. Bummer. Paint Bucket issue was more an issue with a texture I was using & the way I was trying to apply the different colors (user error there). I’m going to install it on my MacBook to see if it’s new thing for SketchUp to not have shortcut keys.


#7

We can both assure you that shortcuts work.


#8

Thank You Guys, The 2018 version works great on my Mac. I’ll have to figure out why the shortcuts aren’t working on my windows 10 machine. Just to let you know the machine is virus and malware free, additionally it lives behind a proxy and back-end cisco asa firewall, so I’m sure it’s not some 3rd party software making it do this. I’m going to try a full re-install just as Dave mentioned. I already tried the repair install and no luck. Thanks again gents.


#9

The default shortcuts should usually get restored without a complete re-install if you click on the Reset All button in Window menu>Preferences>Shortcuts.


#10

Thank You Anssi,
That fixed the problem. I’ve been working with 2018 since last night & its been as smooth & solid as the previous versions. Thanks again sir for the useful input.


#11

thanks @Anssi that solved the problem


#12

That helped me too. I’ve been finding that v2018 wanted F3 to select the rectangle tool, instead of R. It’s possible I had done a test a while ago, and forgot about it. Anyway, it’s back to being R again.

If you don’t mind another shortcut question in this same topic, how do you enter modifier keys when doing a shortcut? I thought that I had done that in the past. I want Paste in Place to be Command-Shift-V.


#13

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.