Sketchup 2018 buffering/hanging

Hi all

My 2018 version hanging most of the time while working. As you know that the 2018 version is still an offline version which mean that the internet connection is not supposed to be an issue.
I have made some changes to my PC with a new solid state drive and new 8Gig RAM, previously only 4gig RAM. It is taking periods of 20-30 seconds to save or just hanging for some reason!!
Previously I never experience this while drawing. I have another CAD program running much better with no such issues!!

I am saving my files on a cloud. What I did due to advice from Colin is to work on a file saved on my PC. I did that, but with the same result!!!

What can the reason be???


Have you changed other things on your computer?
What graphics card is in your computer? Your profile says “yes” wich is not helpfull…
Did you install Windows on your new SSD?
Did you install SketchUp on your SSD?
If so, did you install SketchUp correctly by right-clicking on the installer and choose “run as administrator”
As you see, a lot of follow-up questions…

How large is the resulting SKP file, and how many edges and faces are in the model (as displayed via the Model Info window)? If SketchUp’s feature to validate the model as part of the same operation is enabled, that validation can take many seconds depending on how much geometry is in the model. For models with a few million edges and faces, saving takes 30 to 60 or more seconds on my desktop.

@tweenulzeven @TDahl @colin

Thanks a lot for your advice!!
It was at the end a Google Drive Issue.

I was working ‘online only’ all the time. I have changed that and now everything is 100%.
What I don’t understand is that even the file I “save as”: in documents did buffer as well!!!


@Andries Remember that working on cloud-files can result in unrecoverable files.
There have been a lot posts on the forum about this.
Work local, save or sync to the cloud later…

I hear what you are saying!!!
! will do so!!!

1 Like