Sketchup 2017 will not run Windows 10

I have SU2017 Pro, it will not run. Windows executes and nothing, no splash screen.

Windows 10 Build 20150
Newest nvidia Drivers on GTX1080

Tried reinstalling as admin.
Nvidia control panel.
Intel drivers.

Running out of ideas. Anybody else got this issue?

Which exact version of Windows 10 is it?

Do you know Process Monitor? With that you can look at what SketchUp is trying to do while you’re not seeing it.

Microsoft’s Process Monitor

Win 10 Build 20150.rs_prerelease.200612-1734.
Sketchup appears in process for a split second after launch. What am i looking for in the process monitor?

I can explain Process Monitor later, if you will still need it.

I asked about the Windows version because the last couple of Insider builds did have a problem where even SketchUp 2020 would not launch, or even appear in Task Manager. The solution, if you’re having the issue that other people had, is to update the Windows build to 20161.rs_prerelease.200627-1754.

Working on this now. I did try to install 2020 and it did not work. I will let you know if this works. Thank you!

This solution worked. I appreciate the help.

Happy to hear that!