Sketchup 2017 startup issues

I have been using Sketchup for 2-3 years without problems. I purchased a new computer 3 months ago and downloaded Sketchup 2017 and have been using it regularly since. Yesterday it wouldn’t open. The initial screen opens but when I click on “Start Using Sketchup” it closes and does not startup. I rebooted the computer, I uninstalled and reinstalled Sketchup but still not loading. Any ideas?

Also, if I try the Sketchup Free web-based, how do you load an existing file from my computer?


When SketchUp “closes”, does it display an error, or a “bugsplat”?
You could check if the issue is related to changes in your system (hardware or driver/Windows update) or issues with application settings in your account. If you create a temporary second user account and login there and you can install/open SketchUp then the latter is the case. Try a proper uninstallation and remove/backup the AppData/SketchUp folder.

In SketchUp Free, you can click the “Folder” icon in the middle of the top left menu bar. It is actually the File menu where you can open local files. Note that SketchUp Free is loaded from the web, but executed locally in your browser. Also files that you open are only stored locally (local storage of the browser), unless you save them to the Trimble Connect cloud.

I get a bugsplat. I have solved the problem by uninstalling and reinstalling C++ 2015. Thanks.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.