Sketchup 2017 Seems to Crash on auto save


#1

Hi I just installed 17 yesterday and it seems to be closing completely on auto save! I have it installed on 2 identical computers (except one has a later video card.) and the newer card has had no issue. my card is NVIDIA K2200


#2

Ive disabled plugins, and auto save and it will still just close even if i’m not using it.


#3

You could have added this to Sketchup 2017 crashes when saving. A few years ago saving files began employed OpenGL. Around this forum, the affected computers had AMD cards - and OpenGL deficient drivers. Auto-save issue may be related.

Update driver?

Did you have a bug splat and send it in along with contact info?

It would help if your forum profile listed your graphic cards. 8g Ram is not a graphic card - it’s RAM.


#4

yeah updated driver, the video card is the nvidia k2200, and i’ve sent a bugsplat in with my info, no responce.

Thanks for you response no idea why its going it??..


#5

When you installed SU, did you r-click on installer and choose Run as administrator?


#6

Yes I did, ive uninstalled and ran as general user as well. Then started the program as administrator. It seemed like it was taking about 5 minutes before it closed that’s why I thought it may have been auto save but since I have turned off auto save and plugins via a skript and sketchup still closes if I start and just leave it sit and watch it??
I ran the 2017 sketchup checkup tool but it seems to be giving a incorrect value of 1 mb of memory available on the video card (256 needed min) thought this may have been the problem but I ran the tool on the slightly newer workstation it it gave the same result?? I don’t know I’m thinking maybe the video card just may have a problem with 2017???


#7

@jarroddorney
I just looked up your crash reports. I sent you an e-mail to get some additional information.

The report with Checkup showing a value of 1 MB is a known issue that can occur and is not an indication of an issue with running SketchUp. See the Note under Error 6 in this article: http://help.sketchup.com/en/sucheck


#8

Hi Jarrod
I have a similar crash issue and I am able to repeat it in both 2015 Pro and now 2017 Pro.
I don’t know if your causes/occurrences are the same.

In 2015PRO :
If any piece of geometry (lines, groups, components or any combination) is being actively moved (with the Move Tool) and an AutoSave initiates then often Sketchup will crash. It is very frequent, predictable, and repeatable but fortunately the auto-saved file will be an up-to-date copy of my work. I will only have lost a few seconds of changes to my model. ie. everything is saved prior to initiating the geometry move. The crash is annoying but I can recover all my work in a few moments so it never really bothered me.

In 2017PRO:
Same predictable crashing with geometry move + autosave. However in 2017 the autosave file is not up-to-date. I lose work equivalent to my autosave frequency Preferences setting. ie. The autosave file I recover is always exactly 30minutes out of date. Needless to say this autosave crash issue is now highly annoying. I could reduce the autosave interval but this proportionally increases the chances of a crash. ie. 10min save interval would mean 3x crash probability of 30min interval.

For what it’s worth, I have found other traditional crash causes (eg offset tool problems etc) to be eliminated in 2017.
If Sketchup team can identify & patch the autosave issue then 2017 would be incredibly stable on my setup.

MC