Sketchup Crashes every 3-5 minutes


#1

Been a long time user but in the last few months it has become unusable. I’ve tried older and updated to the most recent versions of sketchup to no avail. So looking for help. Thanks in advance


#2

When it crashes, does it generate a BugSplat? And if so, have you submitted them with enough info to identify you for a reply? The Trimble staff are good at responding to BugSplats when possible.

The time interval suggests there may be a problem with autosave. You could try turning it off and see whether that improves the situation.


#3

Yes It does generate a BugSplat. And yes typically I do submit them,

Just tested it and saving does indeed seem to be the cause. But, even when I manually save it also crashes


#4

It’s been said before…
When you install SketchUp you must select its installer’s icon > right-click > context-menu > "Run as administrator"
Installing it any other way [even if you have admin-powers] can produce weird flakiness !
You can “Repair” the current installation by doing this “Run as administrator” from the installer’s exe file icon.
Choose to “Repair” when prompted.
Relaunch SketchUp to see if it’s improved…

Have you also checked that your Graphics Card’s drivers are up to date ?
It’s always best to have the latest ones installed…


#5

I did original install it as the administrator and then reinstalled it as the admin.

I checked and the graphics card is up to date.

It’s weird I had years trouble free. And then all of a sudden instant crashes. There weren’t any updates or changes at all on my computer when it happened that might have provoked it.

Possibly the strangest bit is occasionally it will auto save and give me a recovery point. Maybe 1 out of 20 crashes will actually generate an autosave.


#6

Where are you saving the file? Which folder? Is it a “cloud” folder like Dropbox or Google Drive? Have you tried saving the file somewhere else?


#7

Typically when I save as, I save it to the desktop and then move it when I am completely finished with it. When it autosaves it goes to “documents”


#8

What plugins do you have installed?


#9

I have never installed/used a plugin with inkscape


#10

found an old copy of sketchup make 2016, uninstalled 2017, installed 2016 and now I can save again


#11

Out of curiosity what type of Graphics card are you using. I have one machine that has a similar issue.