SketchUp 2017 Proxy Error


#1

Hola -

I’m a user of Sketchup 2016 Pro, on 64-bit Windows 7. Never had a problem with licensing, connectivity, etc.

Recently downloaded 2017 update, V 17.1.174… When I launch, I cannot license it because the splash screen displays “Proxy Authorization Required”. I wen through the FAQs (clear cache, login to google.com/ncr, access 3DWarehouse through Chrome, etc) with no problems. I can get to google.com/ncr, I can get to 3DWarehouse, I cleared the cache However, the problem persists.

I contacted Trimble, they sent me a license file that I installed. I now have it licensed…

HOWEVER -

I still get the error “Proxy Authorization Required” in the ‘Learn’ tab of the splash screen, and when I go to Window>3DWarehouse the dialog window is blank…so having the license file working is not enough. Sketchup 2017 runs but obviously with very limited functionality.

Trimble says they changed internally from IE to Chromium in the built-in browser in 2017 vs. 2016.

Any and all help appreciated!

TIA


#2

That’s a network issue on your side…do you have an IT staff that deals with your proxy server? Do you have Chrome installed?


#3

It’s absolutely not on our side, it’s on Sketchup side to understand that businesses are working behind proxies !
We are in 2017 and sketchup isn’t even taking into account my proxy settings from Windows/IE, nor does sketchup provide option to specify an http or https or SOCK proxy ! This is such basic feature for a professional app !
Why don’t you listen to your customer ? WE don’t have to open ports or allow exception in our firewalls, YOU have to allow us to route all Sketchup trafic through our proxy + firewall setup.


#4

I still don’t have it working - and I’m paying maintenance to Trimble yet stuck on 2016. They’ve been zero help whatsoever.


#5

I absolutely listen to customers… but I’m not a salesperson now. I have been, I was very sweet, and I didn’t fix problems, I sold enterprise software. I’ve gone as far as hunt down issues with Comcast (search forums for that one if you think I don’t hunt these issues down). We can tell you that we’re https (port 443), it’s standard web stuff, and in 2017 it’s Chromium, and in 2016 and before it was webkit (your version of IE on PC, Safari on Mac), so 2016 & 2017. We roll through 99.9999% of networks. If your own network blocks it, try making your cellphone a hotspot and see if that works. Good luck.


#6

Cleared browser cache, cookiejar.xml, confirmed that you’re on at least IE11?


#7

I have done absolutely everything - cleared browsers, I’m using IE11.0.96, I have the latest version Chrome.

As for making my cell a hotspot, StraightTalk will shut you down in 10 seconds so I’m not even going to attempt it. As an end user, I’ll say this: 2016 worked perfectly and 2017 doesn’t work at all. We’re a large organization (300+), we have a good sized engineering department, we use Pro/E for 99% of what we do. I/T is strict in their control of the proxy and WebSense and trying to get them to change it is like pulling teeth - and I shouldn’t have to. SketchUp worked and now it doesn’t.

I did get a standalone license for 2017 but that still doesn’t address the problem that 3D Warehouse just shows a blank window. I don’t understand what’s so difficult to fix here for Trimble.


#8

I PM’d @peterbrown77, but for network licenses, confirm that ports 5053 and 50530 are open.

I can neither confirm nor deny any company’s security policies, but I know at a previous internet company, I was never blocked on anything. At a more recent company, despite my questioning what hacks have ever occurred over port 43, I can’t use whois.


#9

" I/T is strict in their control of the proxy and WebSense and trying to get them to change it is like pulling teeth"

I’ve already gone to them with this. So let’s try something different.


#10

This should not be on the customer to adapt but on the seller/provider !
Routing traffic through proxy is a BASIC feature of a professional software, it should not be our problem if you use exotic ports ! why not 80 and 443 like everyone ?
Sketchup doesn’t know how to handle proxy, nor does it ask for proxy authentication, so even if ports are open it can fail !


#11

So what does your proxy look like? Have you looked at it? I opened my wpad.dat file, and looked at it to confirm there’s nothing blocking, which is why there are 2 people complaining and not 30 Million. I’m trying to help Peter with PM’s, and we’ll see if we can fix his.

My favorite line from my proxy:
Proxy file for Netscape 3+ and IE 4+

Hahahaha…


#12

It’s surely not against you Barry as you are the only one trying to help.

Our proxy is an http proxy on port 8080 and then we have an https proxy on port 443.
All traffic goes through this and most of the program get the proxy configuration from IE.
The proxy is authenticated, so just specifying the proxy doesn’t help as you need to login. Sketchup doesn’t even prompt for authentication, it simply does nothing when trying to access warehouse. Specifying system proxy with netsvc doesn’t help.
Only option is to use proxifier (paid software) to force connection routing through proxy. Most of the apps we use can specify their own proxy settings, and if no option for authentication we can use usn:pw@proxy.net:port, but not sketchup.