2016 vs 2017 Network Connectivity


#1

The synopsis: Never had a problem connecting 2016 Pro to 3D Warehouse or licensing. Can not connect 2017 Pro to either. “Proxy Authorization RequiredDescription: Authorization is required for access to this proxy” when trying to license, and a dead 3D Warehouse window in 2017.


#2

does the used/configured proxy need an authentification by user/password?

Check the MS IE for the proxy config, delete the browser cache as well as cookies related to “sketchup.com” and set the security level for the internet zone max to “medium-high”.


#3

I did all that and even set security to Medium (not Medium High). No luck.

On the same computer Sketchup 2016 Pro works and 2017 Pro does not. 2016 can get the license server and 3D Warehouse, 2017 gives me proxy errors. This isn’t right.


#4

The release notes for SU2017 indicated web browser change approach for it. How proxies are handled may have changed so do not assume they by default are the same


#5

The cache on Win 7 + 2017 is HOME_DIRECTORY\AppData/Roaming\SketchUp\SketchUp 2017\WebCache delete that folder and restart SketchUp.


#6

No, I was told it’s now Chromium not IE. But Chromium takes it’s proxy settings from the system…so it comes from IE since it’s Windows machine.


Sketchup 2017 Bug about JavaScript
#7

Sketchup needs to pull out their fingers from their asses and start to understand that businesses are working behind proxies !
We are in 2017 and sketchup isn’t even taking into account my proxy settings from Windows/IE, nor does sketchup provide option to specify an http or https or SOCK proxy ! This is such basic feature for a professional app !
WE don’t have to open ports or allow exception in our firewalls, YOU have to allow us to route all Sketchup trafic through our proxy + firewall setup.