SketchUP 2017 OS X crash or hang on exit


#1

Two different late model (but not 5K) iMacs with have consistently been hanging or crashing on exit since upgrading to SU OS X 2017 from 2016. The problem exists on existing files or new (i.e., new file > draw a rectangle > save > exit > crash). I’ve turned off all extensions, but the problem remains. Tried different templates without success. Tried starting SU while holding down shift without success.

The fact that two different iMacs (one 21.5-inch late 2013, the other a 27-inch late 2013) are exhibiting the same problem leads me believe it’s not a corrupted preference file. Both have NVIDIA GPUs.

I’ve submitted several crash reports.

Ideas anyone?


#2

What extensions do you have installed?


#3

See below, but I disabled all except Dynamic Components to see if it fixed the exit crash/hang, which it did not.

Advanced Camera Tools (SketchUp)
Clean Up 3 (Thomas Thomassen)
Component Replacer (Thomas Thomassen)
Dynamic Components (SketchUp)
Material Replacer (Thomas Thomassen)
Photo Textures (SketchUp)
Podium Walker (Catalog, Inc.)
Sandbox tools (SketchUp)
SU_Podium_V2.5 (Catalog, Inc.)
Trimble Connect (SketchUp)
TT_Lib2 (Thomas Thomassen)


#4

make sure su_dynamic_components is up to date as there have been issues with SU extensions needing updates…

john


#5

I’m running su_dynamic_components 1.4.2, the latest version in Extensions Warehouse.


#6

Are you able to save?

OS up to date?

FYI, tt’s the beginning of what’s essentially a holiday week in the US. So some people may not be around to look up a crash report for a while in a timely manner.


#7

Yes, SU saves before crashing or hanging on Quit. Running OS X Sierra 10.12.1.


#8

Are you getting bugsplats and putting in information that we could search
for your crashes? That’d help


#9

No Bugsplats, only OS X crash reports. Any way for me to attach a report to this thread?


#10

Click on the icon with the up arrow. You may need to rename the file extension with something this forum recognizes, like adding .txt to the end


#11

Crash report.txt (89.9 KB)

Crash report attached.


#12

Ruby.


#13

Barry,

Not sure I understand. Are you saying the problem is with the Ruby interpreter?


#14

A plugin

Most of the extension you have come with SU and/or are downloadable from the Extension Warehouse. In SU, check Window > Extension Manager. Sign in and see if there are any updates. The Ruby environment has been updated. A decent number of plugins require updating to work in SU17.


#15

I tried disabling all extensions, but the crash/hang on exit continues…


#16

The problem appears to occur as the Ruby interpreter is cleaning up for shutdown. That makes is a virtual certainty that an extension/plugin is going astray and corrupting the state of Ruby.

Try renaming the plugins folder temporarily and then restarting SketchUp. That is even more extreme than disabling via the GUI.


#17

Yup, renaming the extensions folder stops the crash/hang on exit. No updates are available for the extensions I’m using, so it’s hard to know which one(s) are at fault other than trial-and-error uninstalls.


#18

The simplest way to home in on the culprit is divide-and-conquer: Reinstall half of the extensions and see if the problem occurs. If so, remove half of those and repeat. If not, remove the first set and try the other half. Halving the number of candidates step-by-step that way will converge pretty quickly on the guilty one.


#19

Don’t need to mess with the extensions that come with SU. They will reinstall automatically when loading the program. Focus on the 3rd-party extensions.


#20

I have the same issue. In the log file, on quitting, I get thousands of these per second until I force quit:

default 19:35:04.194391 -0500 kernel AMFI: allowing exception handler for ‘SketchUp’ (4410) because the process is not restricted.
default 19:35:04.194468 -0500 kernel AMFI: allowing exception handler for ‘SketchUp’ (4410) because the process is not restricted.

Clearly the sw is in some infinite loop, the CPU rails,