Crashing on exit, every time


#1

I use SU 2018 Pro on my Macbook on a daily basis and so far it’s been great. This week it started crashing on exit, every time. I’d not installed any new plugins or updates, it just started happening.

I use SU to create models for Maxwell Render to finish off, so I updated Maxwell in the hopes that the older version of the V4 plugin I was the reason for my problem. Nope. Still doing it.

Here’s the top bit of the crash report I get (in the hopes someone out there knows what it all means :slight_smile: )

Process: SketchUp [1707]
Path: /Applications/SketchUp 2018/SketchUp.app/Contents/MacOS/SketchUp
Identifier: com.sketchup.SketchUp.2018
Version: 18.0 (18.0.16976)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: SketchUp [1707]
User ID: 501

Date/Time: 2018-05-04 12:11:25.526 +1000
OS Version: Mac OS X 10.13.4 (17E202)
Report Version: 12
Bridge OS Version: 3.0 (14Y664)
Anonymous UUID: 2ACE67AF-684C-8CE8-33B2-375B6E7CA911

Time Awake Since Boot: 4100 seconds

System Integrity Protection: enabled

Crashed Thread: 0 CrBrowserMain Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00001ae4cffebec0
Exception Note: EXC_CORPSE_NOTIFY

VM Regions Near 0x1ae4cffebec0:
mapped file 000000013ab4f000-000000013c3d6000 [ 24.5M] r–/r-x SM=ALI
–>
JS JIT generated code 000030e803a00000-000030e803a01000 [ 4K] —/rwx SM=NUL

If anyone has any ideas please let me know!


#2

I don’t know the answer, but I’ve had the same problem too for quite a while. I had trouble in SU Pro 2017, then after upgrading to 2018 it went away for a while, but it’s started again. If I launch SU and then immediately quit, no problem, but if I spend any time working, then upon quiting, either it crashes on quit, or hangs and has to be force quit.


#3

The fragment of report you posted says that SketchUp crashed in the embedded chromium library it now uses for HtmlDialog and various other windows (the report blames the thread named CrBrowserMain). Did the crash generate a Bug Splat, and if so I assume you submitted it to Trimble with info about yourself so they can get back to you?

I think that at one point there was a SketchUp bug on Mac that caused a crash if an extension retained a dialog (even if closed, not visible) while SketchUp quit… something involving unsafe shutdown of the javascript part of the chromium library. If I recall correctly, the SketchUcation plugin was one that triggered the crash, as well as some others. I thought the problem had been fixed. I haven’t seen it in quite a while. Have you checked your extensions to make sure you have the latest versions? What exact version of SketchUp are you running (consult the “About SketchUp” menu).


#4

In the case of my crashes, they also blame CrBrowserMain for the crash. Hang/Force Quit looks a little different.

OS Version: Mac OS X 10.11.6 (Build 15G20015)
Architecture: x86_64
Report Version: 22

Command: SketchUp
Path: /Applications/SketchUp 2018/SketchUp.app/Contents/MacOS/SketchUp
Version: 18.0 (18.0.16976)
Parent: launchd [1]
PID: 4261

Event: hang
Duration: 4.00s (process was unresponsive for 74 seconds before sampling)
Steps: 40 (100ms sampling interval)

Hardware model: MacBookPro10,1
Active cpus: 8

Fan speed: 2167 rpm

Timeline format: stacks are sorted chronologically
Use -i and -heavy to re-report with count sorting

Heaviest stack for the main thread of the target process:
40 start + 1 (libdyld.dylib + 13741) [0x7fff84d055ad]
40 main + 142 (SketchUp + 42034) [0x10439f432]
40 NSApplicationMain + 1176 (AppKit + 25448) [0x7fff8f76f368]
40 -[NSApplication run] + 796 (AppKit + 249330) [0x7fff8f7a5df2]
40 ??? (SketchUp + 342435) [0x1043e89a3]
40 ??? (<4E9292D3-D409-3E34-926B-85031385E64A> + 7671) [0x106949df7]


#5

Unfortunately your force quit log doesn’t show anything that one can diagnose without access to the SketchUp source code, as those two bottom-most entries are opaque. @Barry is this something one of the developers can look into?


#6

BTW, because these happen on Quit, they never produce a Bug Splat to send to Trimble/SU Team with one click, just the generic Apple crash report you would have to go out of your way to report to Trimble.


#7

First, disable all plugins and see if it changes.


#8

There isn’t a simple “safe launch mode” or such is there? I.e., launch SU with the option key down or something and have it load without any plugins?


2018 Crashes on Close! Can't save Shortcuts!
#9

:gear: You can set it (for the CURRENT session) by starting SketchUp from the command line …

sketchup -DisableRubyAPI

REF:

:information_source:


:gear: You can set it (for the NEXT session) via the Ruby Console from inside SketchUp

Sketchup.plugins_disabled = true

To switch it back on you’ll need to set it false in a later session, then restart SketchUp.

REF:



#10

Thank you for the suggestions - we were away for the long weekend and I was out of internet reach. I’ll start exploring the idea of a plugin causing this and saw what happens. Although I find it odd that I’ve not installed or updated any plugins and they all appear to be functioning ok when SU is open.

I’ll post what I find.

Thanks again,

James.


#11

UPDATE - The Ruby Console line didn’t appear to work on my Mac using SU Pro 2018 so I manually deactivated all the plugins and the issue fixed it self. I then enabled them, one by one, to see if the error returned. It didn’t.

So then I tried turning them all off and one again and the error has disappeared completely?? So it looks like it was a plugin but by de-activating and then re-activating it has fixed the issue.

Thanks for the feedback everyone :slight_smile: Just wish I could give you a more detailed explanation of how the problem was fixed for others having a similar issue. All I know is it was one of my plugins, but not which one.

Regards

James.


#12

Guess I’ll have to try that.


#13

Now you have a good idea what to do if the issue shows up again.

Time will tell if resetting all of the plugins acts a long term solution. I hope it does… but keep on your toes for a little while still, those plugins having been reset, probably haven’t been used to their full extent… and the problem might have it’s origins from some process the plugin starts when running in a more ‘active’ state.


#14

I just used Extension manager to disable all extensions and relaunch. One catch I see: Podium is still installed and running. SU hung on quit and had to be force quit. When I moved to 2018, I believe my problems went away until I got around to installing Podium, and that’s around when I started having problems again. I can’t do anything more tonight with this.


#15

I also tried this to de-install all extensions and Podium cannot be uninstalled.
Skp closes nearly every time I quit. I deleted all the rest of the extensions. Maybe Podium is the culprit?


#16

I uninstalled Podium and haven’t been having the problem anymore, so perhaps yes. I think there’s an uninstaller that you run to do that? It was a couple months ago.