SketchUp 2017 does not quit

2017
osx
mac
sierra

#1

The issue is that SU (17.0.18898) does not quit most of the times after pressing the Cmd+Q keys or choosing Quit from the SketchUp menu. I have to do a forced quit. I experienced the problem in SU16 as well and expected the problem to be solved in version 17.
However, anyone the same problem and an idea how to fix this?

Macbook Pro Sierra 10.12.1
SketchUp 17.0.18898


#2

17.1.173 (Mac 64-bit) is the latest release and includes fixes for mac…

slow quitting is often due to extensions, which do you have installed?

john


#3

Hi John,
Extensions:
Chris Fullmer: Arc Center point finder
SU for you: Make face
Podium Light System V2.5plus
SU Podium V2.5 plus


#4

how big are your textures, they can really slow down ‘Save’ and ‘Close’…

Podium may also be processing those materials ‘on quit’, may be worth asking on their forum as well…

john


#5

I’m having the same issue since I updated to version 17.1.173! Version 17.0.18898 ran fine.
Runs better with autosave unchecked in SU Preferences. Seems to occur when Safari or Mail opened. Also been getting Application memory full messages and have to force quit Safari, Mail and SketchUp.
Still very slow with beachball sightings!
Macbook Pro 13" mid 2012
OSX El Capitan 10.11.6
Intel HD 4000 1536 MB
8GB memory


#6

Having the same issues as well … recently re-installed 2017 again for the third time after downloading latest version 17.1.173 … On my iMac with macOS Sierra 10.12.3 8GB Intel core 2 Duo 3,06 GHz. On my compatible MacBook same issues. Also when starting up SketchUp 2017, the interface is black at first. Works fine before loading all plugins but after loading your plugins again in the reinstalled SKP, from the extension warehouse and Sketchucation, the problems start to occur again. Also lots of bug splats. Its some kind of extension problem my gut says, and about the verified and unsigned versions. With the new extension manager. gr. Frank


#7

Your gut is probably right: one or more of the extensions you are loading is buggy. The fact that it works fine before loading plugins is the smoking gun.

The fastest way to isolate the culprit is by a binary search: disable half of the extensions and see if the problem persists. If not, swap which half is enabled vs disabled and test again. If so, repeat by disabling half of the remaining ones. Repeat these steps until you identify the one that must be disabled for SU to run ok.


#8

Thats a good tactic, I can do that with both extension/plugin managers from SketchUp and Sketchucation …I am gonna try that one, thx @slbaumgartner