2014 crashes after startup from dock


#1

Hi
I have recently upgraded to 2014 …
The program continually crashes when opening from the icon in the dock…
I have tried to re-install … but the same thing keeps happening …
Is there anyone out there that has experienced the same thing & has managed to solve the problem ??? Any ideas ???


#2

Have you installed any plugins? Did you try upgrading your graphics driver?


#3

Hi Brian-

From the crash reports it looks like there’s some sort of issue with a ruby extension. When you upgrade, did you copy any extensions over from the older version of SketchUp? There were some major changes between 2013 and 2014, and it’d be best to install new versions if possible.

Marc


#4

Hi
Thanks for the reply …as far as I know I reloaded all extensions from the warehouse … the crashing started happening from the time I upgraded … before I reloaded any extensions …???


#5

Hi
I re-loaded the extensions I use from the warehouse …
Wouldn’t know where to begin upgrading graphics driver …???


#6

It still may be an extension problem. if SU crashes since first installing SU, how - and where - did you install the plugins? Did you install them from inside SU? The plugin directory location changed with SU14. It is no longer located in the program directory. Can you remove all the extensions and successfully open SU?

The Plugins directory has changed location in SU14 to help eliminate some of the permissions problems some users were having in earlier version. On Windows, it is now located (XP) at
C:\Documents and Settings[YOUR USER NAME]\Application Data\SketchUp\SketchUp 2014\SketchUp\Plugins

If you still cannot locate the folder, enter the following code in the Ruby console (Window > Ruby Console) for the plugin folder to appear then press (Return on a Mac):

UI.openURL(“file://#{Sketchup.find_support_file(“Plugins”)}”)

SU14 upgraded to Ruby 2.0 from Ruby 1.8. While that means plugin developers have more tools to work with, some plugins may not load unless they were updated to work in this new environment. Most plugins have already been updated to work in SU14. Check your plugins for SU14 compatibility before installing.

See Installing Ruby Plugins for more details.

What I did to install my plugins is first check if I had a copy of the latest version, add a few plugins to the new SketchUp Plugins directory, and then restart SketchUp to check for plugin loading errors. Plugins that threw errors were removed (renamed with .TXT at the end of the plugin so it would not load while leaving me a record of what I tried to add) and reported to the developer. After that, more plugins were loaded.

Updating your graphics driver.


#7

Hey guys …
You are correct … it does seem to have been an extension problem …!!!
What happened was that each time I uninstalled by just dragging SU from the Applications folder to the trash & re-downloaded, SU would reinstall with all extensions & work fine as long as I only worked on 1 file … the minute I opened a 2nd .skp it would crash.
I found an article in the Knowledge Centre … "Uninstalling or repairing SketchUp " which helped remove all SU files from the system (Library/Application Support & Applications Folder & Library/Preferences …
I followed these instructions … deleting SU 8, 2013, & 2014 … then re-downloaded
Doing this relaunched 2014 without any extensions … & all seemed fine
I went to My Extensions … saw that there was a few extensions marked as incompatible … so installed all the others …
Thats when SU crashed again …!!!
So I then did what you suggested … & began disabling extensions from plugin folder … & found the culprit … RubyWindow v 3.0.5 … when removed SU opens as it should …
So … eventually … all seems fine … (I’m a bit hesitant to be too glad too soon )

Thanks to all that tried to help … it did eventually
Hope this will help others out with similar issues

Thanks guys


#8

Hi Brian,

It’s customary to notify the extension author when an extension misbehaves.
I don’t see an extension by that exact name in the Extension Warehouse.
Can you provide a link to where you found the extension RubyWindow v 3.0.5

-Geo.


#9

Hey Geo
Sorry if I offended anyone …that wasn’t the intention at all …
To tell the truth,I can’t remember where it came from … Although here is the link to their site … http://www.rubysoft.nl … but as I said I’m not entirely sure where it was originally downloaded from … is it possible that it was bundled with another extension ?
I will go to their site asap to notify them of the issue

BrianG


#10

Nor was it mine :smile:

SketchUp recently adopted an updated version of Ruby.
And so occasionally stuff happens to extensions that are unexpected by users and authors alike.
Extension authors certainly aren’t offended by letting them know there’s a problem.

-Geo


#11

Hey
Glad we good …
Anyway …I went to their site to notify them of the issue … & it seems that they were aware of it … only for Mac users & only with the previous version … v3.0.4 …
Seems to be a SU issue which apparently will be fixed in 2015 ???
(as per their Customer Support Page … topic 1.2 …)

I’m so glad to have 2014 working properly … I’m going to build my own windows for now …


#12

It’s often said here, “The best components are those you model yourself”.
Tis true, tis true, tis true…

-Geo


#13

This forum needs some way of IDing the OS. For in your case, your graphics driver is updated with OS updates - so be sure your OS is up-to-date to get the latest and greatest driver. Windows is different.

And let us thank Marc for quickly focusing the troubleshooting to the extensions. Looking at my first response, it’s interesting that it was my first guess based on the info in your original post. I just have gut-feelings and years of experience to throw things out. Kudos to you running with it and finding the naughty child.