SketchUp 2017 Not Responding - Driver Display Stops

I have downloaded and am trying to run SketchUp Make 2017. I am able to open it. However, once I use any of the tools, the program stops, the screen goes black and I get this message: “Display driver stopped responding and has recovered.” And then SketchUp says “Not Responding”. I have to close SketchUp. It won’t recover on it’s own.

I ran SketchUp 2017 Checkup and get all green. Everything seems to be running fine.

Windows 7, AMD Radeon HD 7770 graphics card, 16GB of ram.

I have also uninstalled and re-downloaded SketchUp Make and still get the same results.

Any and all help is appreciated. thanks.

Leave the software installation on your computer as it is.
Right click the SketchUp installer you downloaded and select “run as administrator”.
This is the correct way to install it, this may fix it.

It could be graphic card related, but checkup reports ok.

Or if that is not successful, you could try this link https://help.sketchup.com/en/article/60107

To download Sketchup 2016, which is slightly less demanding on your computer.

Thanks, Thorleyian.
Sadly it didn’t help. I did uninstall 2017 and downloaded 2016. And 2016 seems to work great. Not sure why that is, but at least I can use it during my trial. Any thoughts on why 2017 doesn’t work, but 2016 does, would be appreciated.

You may need to update your AMD graphics driver.

and if nothing helps drop the Radeon and buy something capable as e.g. a nVidia GeForce GTX 1050Ti (~3x faster) or better.

@kate5599, I’m sorry to hear you’re having trouble with SketchUp 2017.

We’ve seen some issues with SU2017 on Windows and certain AMD GPUs. I’m curious if you’re hitting one of the problems we’ve seen before. When you have a moment, could you try the steps described in this help center article: https://help.sketchup.com/en/article/3000345

Once you’ve done this, it would be great if you could fill out the survey that’s linked from that page and also report back here whether those steps helped or not.

Thank you,
Thayer

1 Like

I ended up uninstalling 2017 SketchUp and installing 2016. 2016 works fine without any needed help or changes.

When needed, we’ll try 2017 later in the future.

Thank you for all the help. Unfortunately, none of the ideas worked except for trying 2016.

droping the Radeon and buying something capable (starting from ~100 bucks) would help.

Have you tried the latest Radeon driver? The newest version was released about four days ago…

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.