[PROBLEM] Sketchup 2017 closes unexpectedly

closeall
error
bug

#1

I just install my Sketchup 2017 Pro version and activated in same minute.

To my amazement, just minutes after being open and not modeling anything, the program simply closes.

I received the message from Windows 10 to say that the program had a problem and had to close.

Only once, the SU2017 showed the BUG SPLAT screen

I’ve run the Sketchup 2017 Ckeckup program and my equipment is perfectly capable of running the program:

Notebook: Asus G750JS
Bios: G750JS.207
Processor: Intel Core i7-4710HQ CPU @2.50GHz (8CPUs) 2.5GHz
RAM: 16384MB
Graphics Card: NVIDIA GeForce GTX 870M
DirectX 12
OPEN GL: 4.4

My Su2016 Pro copy works fine. Since installed, never ever a had a BUG SPLAT or any kind of error!!!

Any help?!

PS.: Sorry about my poor english, i’m portuguese. :frowning:


#2

Did you fill in your identifying information on the BugSplat window and then submit it to Trimble? If so, one of the staff there can look up the report and give you a diagnosis of what caused the crash.


#3

Maybe some sort of ‘rights’ issue or shouldn’t that happen anymore with v2017 ? Did you install it with administrator rights?


#4

Two ideas.

Have you updated the drivers for your Graphics Card ?

When you installed SketchUp 2017 did you do it in the proper way ?
You must do it like this…
Find the installer’s exe file [probably in your Downloads folder?].
Select it, right-click > context-menu > Run as administrator…
This will ensure that it is installed correctly.
Having administrator powers is NOT the same thing as running it properly - double-clicking on the exe or choosing ‘Run’ from the context-menu will not install SketchUp in the right manner.
Because you have SketchUp 2017 installed you can re-run the installer and choose the ‘Repair’ option when it is offered to you, this ought to correct the installation errors, without the necessity of uninstalling it and then reinstalling it…


#5

Yes, i submited to Trimble…but i forgot to take note of problem description. :frowning:


#6

I didnt remember…but i it YES during instalation.

Can i reinstall with ADMN RIGHTS over this instalation or is better to desinstall and reinstall with admin rights?


#7

I will try and report the result. Thank you.


#8

If you have v2017 already installed and then reinstall using ‘Run as administrator’ - then it should ask you if you want to ‘Repair’ the installation, say ‘Yes’…
That should fix it…


#9

Just finish reinstall (repair) SU2017 with Admin rights and upgraded my NVIDIA graphic drivers too…and…

…SU2017 crashed (without Bug Splat screen) after 3 ou 4 minutes working on a project. :frowning: :frowning:

I’m very, very sad with this…i dont belive i need to format my PC…and worst of that…i dont have the warranty that will work after that. :frowning: :frowning: :frowning: :frowning:

This SU2017 is so…sooooo mutch faster than 2016 version that i already love it after a “litle moment” working on it.


#10

Have a look at your openGL settings in SketchUp; Window-preferences-openGL-Graphic Card details.
You’re 100% sure SketchUp is using the GTX chip and not the embedded HD4600?


#11

I’m 100% sure of that…those settings were the first thing i look for.

My settings are:

4x Multisample anti-aliasing (may i use more?)
(checked) Use fast feedback
(unchecked) Use maximum texture size

Graphics Card: NVIDIA GTX 870M


#12

Wildly guessing here but have you tried changing the ‘multisample anti-aliasing’ values in the openGL settings?
The same for enabling/disabling the ‘fast feedback’ ?

Its just guessing but these are easy to check and maybe you’re lucky…

Edit: also - did you already install plugins in SketchUp? If so - give a try without them.


#13

I’v just installed one plugin (skater) but the error happened before that.

4x Multisample anti-aliasing (may i use more?)

Use fast feedback (what this setting does?)


#14

Just try changing the settings. If you’re lucky some combination won’t make your SketchUp crash anymore. For more info see here: https://help.sketchup.com/en/article/3000142#set-opengl


#15

The strangest and funniest is that SU2016 is running perfectly and not having these strange problems … in fact, since I installed it, I do not remember having a single crash or bug splat even working with licensed plugins like vRay etc…etc…


#16

SketchUp 2017 has a new way of displaying graphics so it could be related to your problem.


#17

Do you by any chance have any 3Dconnexion hardware, and associated software and plugin?

All but the latest drivers could have problems and ran away with memory leading to crash.

If so, updating to latest version of 3Dconnexion software and drivers should fix problem.


#18

What you mean by “3D connexion hardware”???

If you are talking about “NVIDIA control panel” yes i “gave orders” that SU2017 work with GTX 870M graphic card insted of Intel HD4600 onboard graphics card.


#19

He’s talking about a special kind of mouse (3d mouse). If you don’t recognize the brand name 3dConnexion you probably won’t have one.


#20

You would know if you had one, I think, as maxb says.

Most likely it is that SU 2017 is more demanding of your graphics card and driver than previous versions of SU.