Sketchup 2017 crashes on launch (Mac)


#1

I’ve just installed SketchUp and want to try it out but it crashes upon launch on my MacOS 10.11.6 El Capitan MacBook Air and also on my El Capitan 2012 Mac Book Pro. I tried many things including re-downloading it, cleaning things up, and finally I see various complaints about case-sensitive file systems, which I have, not being supported. I cannot find any way to get around this or any way to download an earlier version of Sketchup Make so it would be good to know if this problem is surmountable. My child is learning about Sketchup at a camp and would like to show us and use it at home but so far this has been multiple hours of frustration with no progress made.

I cannot convert my file systems as those will break other projects that have been working well for years. So I hope there is some way to manage this. I could try to create an external drive with no case sensitivity and install it there but it would be good to know if that has a chance of working before devoting more time on this.

Thank you for any help.


#2

I keep old versions of SU around for testing my extensions, but because my SSD is small I migrate the ones that I never use otherwise to an external drive. I currently have SU 8 and SU 2015 running there. SU 8 runs into an occasional glitch because back then some things were saved in the system’s /Library folder where there are write permission issues in new versions of Mac OS. Newer versions keep everything in the user’s ~/Library so I don’t think there would be a problem.

I would install the app first in the standard way on your internal disk, then copy the SketchUp 201x folder from the /Applications folder to your external drive. Test that it runs, and then delete the original from /Applications. Doing it that way makes sure the installer doesn’t get confused about where to put things.


#3

as far as I’m aware it’s only the SU ruby extensions that break case-sensitive systems, so you could try running without ruby turned on…

there should be post’s here [somewhere] with the Terminal.app command needed for launching without ruby running…

john


#4

John I’ve seen examples in which the dynamic loader failed to find dylibs because the capitalization of the dylib didn’t match what was compiled into the app!


#5

Thanks for the suggestions. Neither has worked- I still get a crash to BugSplat upon launch from an external drive, formatted specially for this project, as not case-sensitive.

I tried the command line launch “open /Applications/SketchUp\ 2017/SketchUp.app --args DisableRubyAPI YES” to suppress Ruby which also did not work.

This is disappointing as I’ve spent a great deal of time on this on this without any success yet.