Busplat when opening SketchUp


I’ve been using sketchup for a while now but since a few months I can’t even open it. Every time I try to open the software it crash with a bugsplat message.

If you could help me it would be great



Hi Sandra,

You are speaking of the Desktop edition of SketchUp Make (not Free, pls correct forum profile) …

SketchUp 2017 MR 3 (version 17.3.116 for Mac only) had some fixes related to High Sierra.

Have you installed the SketchUp 2017 Maintenance Release 3 for High Sierra yet ? IF not …

… you can also try out the web based SketchUp Free until you get the desktop edition running again.

In your browser (Chrome or FireFox suggested) navigate to:

I have gotten similar crashes on startup when my laptop was set to energy saving mode. That was Windows 7 though.

Thanks for your answer but it’s still crashing. Can I use a saved design with the online version?

When it crashes, do you put a name or email address in the bugsplat submission form? If so, I can look it up in our database to see why it’s crashing.


1 Like

Yes, it is called “Insert” from the folder menu (top left) then click the computer icon to browse your local drive for the file to insert. (And delete the Josh guy anytime.)

Even the online version is not working properly.
It just super slow, I can’t do anything.
Do you have another suggestion?

Yes answer Marc. He can look up the BugSplat error in their database. He works for SketchUp.

I just send the crash report #89103.

Are you possibly running on a case-sensitive installation of OS X? That’s the tag I have on that particular crash identifier.


If so, SketchUp doesn’t run properly on case-sensitive installs of OS X. However, there is a bit of a workaround if you can get by without using any Ruby extensions.

You’ll need to open the Terminal application (/Applications/Utilities/Terminal.app) and run SketchUp with this command, which will disable the ruby library:
/Applications/SketchUp\ 2017/SketchUp.app/Contents/MacOS/SketchUp -DisableRubyAPI YES_

Using the online version of SketchUp is also a possibility as Dan has suggested, although it’s not as full-featured as the desktop client version.


Sorry I’m french and I don’t understand what means case-sensitive in that case. Could you explain?

I also try to open the Terminal application and copy past: /Applications/SketchUp\ 2017/SketchUp.app/Contents/MacOS/SketchUp -DisableRubyAPI YES_
but nothing happened

I don’t have any idea

“case-sensitive” means that OS X looks at whether letters are capitalized when it’s looking for a file. SketchUp doesn’t work on a case-sensitive machine because it uses the wrong capitalization when opening some files. Sensibilité à la casse — Wikipédia

You can check if your computer is case-sensitive by running this command in the terminal:
diskutil info /
And tell me what it says next to “File System Personality” and “Name”. For example, my computer says:
File System Personality: Journaled HFS+
Type (Bundle): hfs
Name (User Visible): Mac OS Extended (Journaled)

Content (IOContent): Apple_HFSX
File System Personality: Case-sensitive Journaled HFS+
Type (Bundle): hfs
Name (User Visible): Mac OS Extended (Case-sensitive, Journaled)
Journal: Journal size 40960 KB at offset 0xe8a000
Owners: Enabled

This is what appeared on my screen when I tried to go through the terminal

Remove the space between the dash “-” and the word “DisableRubyAPI”

The last part of the command should be:
Sketchup -DisableRubyAPI YES


39 PM

Still the same

Install SU into your Applications folder first…

your message tells me your are trying to modify SU in the installer, not in Applications…


Maybe it’s easier to manually move the misnamed ruby scripts out of their directory? I don’t know where they are stored on Mac but I’m thinking it might be easier than using the terminal.

Edit: Or rename the files.