Sketchup 2016 non responsive on Windows 10 Pro

nvidia

#1

Hi All,
I have been using sketchup for a couple of years. I got a laptop with specifications mentioned below.
My sketchup Pro2016 is extremely slow when working on models like small residential villas. It becomes non responsive when models are added ( upto 15mb size ) from Warehouse.

I also use Vray 2.0 for rendering. If I open the file created on my desktop and use this laptop for render…the render times are same. But while modelling its non responsive.

My Laptop Specifications :

Processor - Intel i74810MQ @2.8 GHz
RAM - 16GB
Operating System - Windows 10 Pro 64bit
Graphics Card - Nvidia Quadro K2100M

It would be great help if anyone can help me with the settings that I need to look at to improve performance.

Thanks in Advance


#2

Before doing deeper troubleshooting, did you already update the graphics driver? Is it up-to-date?


#3

Hi, Thanks for your reply. It is ‘Up to Date’ as I see it.

It is set to update everyday for Nvidia Card.


#4

What happens if you turn off Hardware Acceleration and Use Fast Feedback in SketchUp’s Preferences>OpenGL?


#5

Hi Dave, I just read that in some other website. I am trying it to see if it works.


#6

Doesn’t seem to be improving…I wonder what I need to look at.


#7

Hi All, Any other suggestions please let me know.


#8

Are you running the latest update of SU2016 ? (16.1.1449)

Have you verified that Nvidia Control Panel is set to run sketchup.exe using your Quadro GPU ?

Are you using a “fast style” for your modeling scene ?

Does your modeling scene have performance hogs like shadows and textures switched off ?

… and have you read and applied these techniques …

* A “modeling scene” is a scene page specifically set up for fast modeling and not for display, output, rendering or LayOut viewports. Mine is named “Work” in my template.


Lastly, have you compared against SketchUp 2018 running in trial with the Windows 10 slow selection patch applied ?


Very slow and freezes after select tool
#9

Hi, While I read and try the rest, here are a couple of things which I checked. It seems to be fine I think. Please tell me if it is otherwise.

image

Thanks for your reply. I will try other suggestions and get back. Thanks Again