Sketchup 2016 does not run on windows 7. HELP!

installation
windows
2016

#1

Hello there I need Help.

I’ve managed to download sketchup 2016 for windows and now it doesn’t load :confused:

I’ve managed to update the graphics, run as administrator, upload and instal microsoft NET 4.5, but NOTHING works!!!

windows says that is an incompatible application… is this possible? what can I do???


after I click in start nothing happens…

Can you help me? please!!!


#2

Hi @renatacandeias,

In the event that this is a graphics card related issue, I recommend updating the driver for your card first. It’s possible that SketchUp is crashing when initiating the graphics engine while it’s attempting to work with the graphics card.

The other possibility is that the drawing window is hidden or hanging out on a second monitor. If this is the case, one option is to unplug the second monitor, launch SketchUp and click Start using SketchUp again.


#3

hello Tommy! (and thank you for your answer)

I already updated the driver AMD…

:confused:

and I’m in a laptop, no second screen…


#4

Any chance you are trying to run the 64bit version on a 32bit system.


#5

Good thought, Box. But I believe that the 64bit installer detects if it’s trying to run on a 32bit machine and it’ll quit with an error.

I just had another idea, though, based on the fact that you’re using a laptop. Is the laptop plugged into a power supply? Some laptops, when they’re running on battery power, will degrade graphics processing or switch to a lower-powered integrated card which may have trouble running SketchUp. If your laptop is running on battery power, try plugging it in and see if that helps.


#6

Another random thought regarding the “incompatibility”: Have you installed all the Windows updates to your Windows 7, especially Service Pack 1?
If you are using a laptop, is SketchUp set to use your AMD card instead of an Intel motherboard/CPU HD graphics chip in the graphics card’s control panel 3D application settings? “Automatic” selection usually doesn’t work.

Anssi