SketchUp 2015 Workspace Not Saving


#1

Hello,

We’ve installed SketchUp 2015 for one of our users and when opening up and positioning toolbars they are not saving automatically, forcing the user to open them up and position them every time the PC is rebooted. Is there a way to save the layout?

We’ve installed (and reinstalled) both the 64bit and 32bit versions, do not have any extra add-ons installed and do not get any load errors.

We’re running Win7 Pro 64bit and our users do not have admin rights to the machine. I’ve given the user full access to the Sketchup folder, but it’s made no difference.


#2

Did you explicitly install SketchUp ‘as an admin’ ?
Have you [re]set the SketchUp.exe Properties > Compatibility ‘to always run as administrator’ ?
Either of these might be giving issues ??


#3

I’ve just installed it using default values under my admin account, I gave the user full access to the folder, so the .exe shouldn’t have any admin issues. The user can work, save and do everything in the program but the toolbars always reset.

I have made the changes to the .exe anyway and will report back as soon as we get a chance to test it.


#4

That’s not what I asked.
When installing you can simply double-click to run the ‘installer’ exe, OR you select the ‘installer’ exe and get a context-menu option to ‘run as admin’ - this is not the same as just ‘being an admin’.
:tired_face:


#5

Have you checked out this thread: Workspace saving/management in Lab installation

Thank, AlexB


#6

All the toolbar and inspector window positions are saved into the User hive of the registry.

Are you using some registry locking software (that resets the registry like Deep Freeze) ?

Do you use ACLs (Access Control Lists) to prevent users from installing any new applications ?
If so, you can use https://helgeklein.com/setacl/ to allow access to the SketchUp hive (or a specific SketchUp version hive,) see:
https://helgeklein.com/setacl/documentation/command-line-version-setacl-exe/


#7

I ran the file under my account (double click) not through Run As, sorry for the confusion - I just wanted to clarify that they have full access to the folder.

No, we’re not running any software like that. It’s just standard windows user access groups, so the user account won’t have modify access to the registry. Is this a known issue when a user doesn’t have admin access?


#8

So have you actually tried to ‘run the installer as admin’ ?
And have you tried setting the SketchUp.exe to 'always run as administrator ?
Did it change anything ?


#9

I’ve never heard of the user hive of the registry being locked, as “standard.” I can see the Local_Machine, Classes_Root, and Current_Config hives being locked.

It is the first I’ve ever heard of anyone having this specific issue.

@Barry ?


#10

Yes, I changed the properties of the .exe to run as admin, opened some new toolbars this morning. I’ve just rebooted it and checked it again now and it seems to have saved, so that might have resolved it.

I will get the affected user to confirm this tomorrow morning and let you know the results.


#11

Thank you very much for your (and everyone else’s) help, setting the .EXE to run as admin seemed to do the trick. Such a small change too, wouldn’t have thought it’d have resolved the issue.


#12

the problem is caused by installing in the context of another user account as e.g. the admin account which prevents saving to the user branch of the registry of the user running SU.

installation and first launch under the user account running SU regularly avoids all problems of this type.