Sketchup 2014 won't go to Make after 8hr Trial


#1

I’ve been pulling out my hair, digging around the internet but it looks like Sketchup is completely finished on my machine now.
It ran for 8hrs as Pro and it was supposed to “gracefully” become Make but I just get “Expired” on the splash screen.
I’ve tried to uninstall then reinstall but Make is now only available for Windows 7 (I have Vista).

Is there no way to turn my “expired” installation into Make or do I have to look for other software do you think?

Thanks.


#2

Have you tried an earlier version?
Downloading older versions — SketchUp Help


#3

Hi. One common pitfall that causes this is accidentally installing Pro instead of Make. Pro will expire after the trial period. Can you post a screenshot ?


#4

They are all Pro downloads.


#5

I had downloaded 2014 “Make” and I was learning it, but it told me after a while I should update to the latest version (2015) which I did.
Of course, after I installed 2015 it told me it wouldn’t run on Vista.
So I uninstalled it and downloaded 2014 which was only available as “Pro”; that I read on here would gracefully go to “Make” but it didn’t :smile:
Now I can’t run any version. Never mind, I think it is just how it is.

Thank you, I will give up with CAD.

*** I have uninstalled it again since my first post so I am unable to post a screenshot. But it will have been “Pro” after I downloaded for the third time (“Make 2014” not being available of course.)


#6

Do you still have the original SU14 EXE installer on your hard drive before SU15 came out?

There was no need to uninstall the older version of SU when version upgrades come out. The new versions are independent installations.

I wonder if restoring your computer to an earlier state would restore


#7

Don’t have the installer.
PC can’t be restored to an earlier state.


#8

what is wrong with that app?!

I have the same experience.

Pro version is expired and I can’t transfer it to free. And after uninstallation and new installation (personal version) I have the same. It says Pro is expired.

???


#9

I had the same problem but then found This website With 2014 make.