SketchUcation Pop Up every time on open Sketchup 2020

Recently upgraded to SU2020 but I get this pop up every time at start up. Does anyone know the fix?

image

Do you have the most recent version of the Sketchucation extension?

Did you install SketchUp 2020 correctly? That is, did you right click on the downloaded installer and choose Run as administrator?

As far a I know. I downloaded SK2020 and activated it. And yes I downloaded the latest SketchUcation extension and even re-installed SU2020 but those did not fix it. Sent a message to SU folks and they said its probably the Sketchucation plug-in and to post the question here.

That doesn’t indicate that you installed it correctly. To avoid any doubt, quit out of SketchUp. Find the installer file you downloaded. Right click on the installer, choose Run as administrator. Then choose Repair.

DaveR, Just did as you noted and still pops up. I have SketchUcation v3.18 which I downloaded this morning.

image.png

How did you install it?

Sorry, SU or Sketchucation plugin?

I assume you followed my instructions for repairing the SketchUp installation. So how did you go about installing the Sketchucation Extension Store tool?

Yes, I followed your instruction on how to install and repair SU. I downloaded the plug in per a link from sketchup support to download the latest version. I downloaded the rbz file, opened SU, extension manager, install extension.

You can open the Extension manager and uninstall the malfunctioning extension.

As the ‘author’ of the SketchUcation Toolset I am perplexed about this.
Why are you the only user to report this repeated message ?
Also posting on SketchUcation.com itself might have got a quicker response…

So the reason you would get that message would be if you have a much earlier version of the toolset installed and you have now installed the latest version, and because of changes to it a restart is necessary to sync all files.
In the newest versions of the toolset a restart is rarely needed… although it does no harm.

Looking at the code…

As the files load a variable named ‘tidied’ is set ‘false’
It then checks for old [obsolete] legacy files, if any are found it deletes them and sets ‘tidied’ to ‘true’.
If the variable ‘tidied’ is found to be ‘true’ a message to restart is shown, because you need to restart to complete the process…

The files it deletes if found are all in the hidden folder:
C:\Users\USERNAME\AppData\Roaming\SketchUp\SketchUp 2020\SketchUp\Plugins\SketchUcation
The two files are named:
Upload2sketchUview.rb
and
sketchUcloud.rb
a file named
Data.txt
and a …v1.1.1… file are also removed but that doesn’t affect the ‘tidied’ status.

Please check for those files in that subfolder…
Manually delete them if they are there…
Since it’s unlikely any of these legacy files are in your folder it’s a mystery as to why the tidying check is set ‘true’…
@DaveR’s idea about incorrect installation of SketchUp causing permissions problems [perhaps blocking the old-files’ deletion] seemed valid, except that unless you have copied over [or installed] a really old copy of the toolset’s contents ‘tidied’ would be false anyway…

Your description about the installation is still a bit muddled, especially about how you got the SketchUcation Toolset’s RBZ file…
Download the current RBZ from here, and install it using the Extension Manager > Install… button…
https://sketchucation.com/pluginstore?pln=SketchUcationTools

Restart SketchUp after installing it.
Do you still get the ‘restart’ message as SketchUp starts ?

If so please provide the following extra info.
Open the Ruby Console and type [or copy/paste] + enter the following, and report the returned values…

tidied
should be false

then
SCF::VERSION
should be 3.1.8

then
File.exist?(File.join(SCF::FOLDER, "sketchUcloud.rb"))
should be false

I see that the code does ill-advisedly define ‘tidied’ outside of the main SCF module’s name-space, but even if some other code is also [re]setting it, the setting ‘false’ and maybe ‘true’ are done in quick succession ? What other plugins do you have loading ?

:mask:

First, thank you for your help. Second, I’ve only been been using SketchUp for the last 2 years and still learning and using a few plugins and I’m not too computer savvy. So very likely I did something wrong. Anyway, I followed your instruction and did not find the two files you mentioned, re-installed the rbz file from your link and re-started sketchup. Still get the pop up message. I unistalled the SketchUcation extension, re-started, no pop up…After this I’m clueless on the Ruby stuff…sorry.

image

Did you also remove the SketchUcation folder in the same directory? The problem file is probably there. Try removing both the folder and the .rb file and then start SketchUp and install the extension again.

No SketchUcation Folder there

image
You can see from your screenshot [which I assume is tken from your Downloads folder?] the RBZ files downloaded from SketchUcation always have their version appended - e.g. Mirror_v11.0.rbz
Your SketchUcationTools.rbz doesn’t have that - the current RBZ is SketchUcationTools_v3.1.8.rbz
Why is yours different ?
Have you renamed it ?
It has the correct date and size…
You say you got it from the link etc, so I must assume that.
If you uninstalled it using the Extension Manager the RB loader file and its subfolder will have been removed.
It’s a pity you didn’t run the tests in the Ruby Console as I outlined.
Opening the window from the SketchUp menu and copy/pasting some short text is not rocket science…
Have you tried reinstalling from the latest RBZ ?
Do you get the same error-message ?
Can you please try my simple investigations…


EDIT:
I have sent you a Private Message [click your user icon to open it]
Download the attached SCF_loader.zip file.
Extract it to get the SCF_loader.rbs from inside it - I can’t attach an RBS directly.
After reinstalling the SketchUcationTools from the latest RBZ, close SketchUp.
Assuming you still get this weird error message, open your Plugins folder [as you listed earlier].
Open the SketchUcation subfolder and replace the SCF_loader.rbs with the new one [drag-n-drop it into the subfolder.
Now restart SketchUp and the error-message should have gone and the toolset should now work from now on…
Note that changing this RBS in the subfolder will make the signature ‘invalid’ when you look at it in the native Extension Manager dialog, however the toolset will still work OK provided that the Extension Manager’s settings have the Extension-Loading-Policy as ‘Unrestricted’…

If this works let me know and I’ll incorporate the fix in a future update…
But I still don’t know what this is only happening to you !

1 Like

Finally found the Ruby Console in the SU Window. I did replace the SCF_Loader file as you said. And re-loaded the SketchUcationTools_v3.1.8.rbz which was the very first one I installed.


image

The Ruby Console message shows you have installed the fixed RBS I provided - hence the ‘tidied’ error message - as that variable is no longer defined.

The SketchUp tools versions you have installed is old [v3.1.5] the RBZ you downloaded from SketchUcation has an RBZ name-ending in the latest version “v3.1.8”
Install a that again - your earlier view of the RBZs showed one without any version info - that could be the old one you have installed ?
Ensure you install the correct one - re-get it from the link I gave to be sure - do NOT think to rename it as it downloads…
If you install the latest v3.1.8 if will reinstall the SCF_Loader.rbs file which might still cause that message issue !
Do that, see if there’s an error, if not then leave well alone !
If that error has returned replace that file with the one I PM’d you…
The then Ruby Console message should be as you posted BUT the SCF::VERSION will be 3.1.8