Sketch Up Pro not responding

Hi,

I have just downloaded sketch up pro via the apps anywhere software. Sketch up seems to launch just fine, but when I go to start with a template it informs me that the paths for different functions of sketch up are not working properly. It tells me that this can be fixed by going on preferences, but when I try to do so I am met with a ‘not responding’ error message.

Are these two issues linked?

Try downloading it from SketchUp.com/download/all (the official source) and then when you install it, make sure you right click on the downloaded installer and choose Run as administrator.

Thanks for the suggestion Dave! But unfortunately, still not working

Did you install it on the C: drive?

Show us a screen shot of the message you are getting.

Sketch Up 1

This is the first error message that appears, when I try and open a new template

So have you done what it says?

I am then met with this ‘not responding’ notification when I try to solve the first error by trying to get to ‘preferences’

Most likely this is due to incorrect installation. You didn’t answer my question about where you installed SketchUp.

It is installed on the C: drive yes

Make sure SketchUp is closed. Find the download installer, right click on it and choose Run as administrator. Then choose the Repair option. After it completes, shut your computer down completely and do a cold reboot.

Hi Dave, did all of that and unfortunately still no luck.

You can use it online for free, so its not desperate. Just annoying that it doesn’t work. It is probably an issue with my laptop if I’m honest. Anyway, thanks for your help Dave! All the best

I expect it is an issue with your laptop because normally the folder locations are set up automatically with a correct installation. The Online version doesn’t use those folder locations so it’s understandable that it would work and for hobby use, it’s certainly a viable option.

What is your user name on your computer? Does it have any unusual characters?

If you want to dig into what SketchUp has recorded for those file locations you could open the PrivatePreferences.json file which is found in User/AppData/Local/SketchUp/SketchUp 2021/SketchUp. The AppData folder is normally hidden so you might want to make that visible in File Explorer.

I had not heard of AppsAnywhere. Do you get better results if you download the installer from this link?:

Windows SketchUp 2021.0.1 installer

The part about the paths being wrong could have caused by installing and testing SketchUp under an admin user, then trying SketchUp as a different user. The file Dave was pointing to can be reached by copying and pasting this text into File Explorer:

%LocalAppData%\SketchUp\SketchUp 2021\SketchUp\

While logged in as the regular users, close SketchUp, go to that folder, and rename PrivatePreferences.json. Open SketchUp again, and all of the paths should be reset to the default values.

Okay, giving it another go here. Rather than do something wrong, I’ll just ask - what do I do from this point?

Open that file in a text editor like Notepad. In the Edit menu select Find and then search for “File Locations” with the quote marks. Show us a screen shot of what is displayed under File Locations.

Did I do that correctly?

Actually I didn’t catch it but you opened the wrong .json file.

You need to follow the path I gave you. Not to Roaming.

That is the wrong folder. You need to be in AppData\Local, not AppData\Roaming.

My path earlier was for 2021, this would be the folder for 2020:

%LocalAppData%\SketchUp\SketchUp 2020\SketchUp\

Why did you install 2020? Why not install 2021 since that’s the current version?