Sketch up on Mac - Materials is stuck in colours and can't view textures etc

I usually use my PC but I recently also started using my MAC as well. I had the materials tab options working fine until I changed the colour of an item, now I can’t get out of colour and go back to viewing other materials. I have tried reloading the model, I also send the drawing back and forth between computers and it’s still the same in the recent one I opened.…. I have a feeling its one of those little un-obvious MAC things that I’m missing??

Hard to tell exactly what you’ve got going on based on that description. Did you by any chance turn on Color by Tag? If you share the .skp file I expect we can sort you out in a couple of seconds without any guessing.

Ok…can you suggest the easiet way to do that? I tried to upload it but it’s too big….

Upload you file to DropBox and share the link.

not sure if I did it right……

So basically, I want to access materials but can only get colour….

I opened your model and can see the textures in it. Do you not see those materials? What is it you see in the In Model materials?

There are a lot of them and many duplicates as well unused ones. This is after purging the unused materials.

Maybe you can show a screen shot of what you are seeing.

FWIW, I fixed the incorrect tag usage. ALL edges and faces should be untagged. Only groups and components should get tags.
Screenshot - 2_18_2021 , 10_43_59 PM

Purging unused stuff got rid of the following:
Screenshot - 2_18_2021 , 10_44_23 PM
A nearly 40% file size reduction.

It may be that your model is overtaxing your computer if you don’t see the textures. Maybe purging unused in Window>Model Info>Statistics will help. It’s still unclear to me what you are seeing, however.

Your model would benefit greatly from proper use of components and groups and you should be ensuring correct face orientation with no exposed blue back faces. Here with the face style set to Monochrome you can see lots of exposed back faces and you can see that all of the selected is loose geometry.

Wow, thank you! this is my first month using sketch up for achool so I’m slowly recognizing my mistakes, but this is super helpful. So the blue faces are not connected properly?

I can see the materials in the model, I just can’t get to the materials in the materials panel, when I open it, it’s on color and I don’t know how to get to the other materials….

They aren’t oriented properly. You shouldn’t have any visible blue back faces in your model.

Is it just a case of needing to click the brick icon at the top of the Colours panel on the Mac and then selecting a texture collection?

Oh my……haha……duh, I swear I tried that.

Last question, can you recommend an effficient way to correct the geometry? should I delete the whole wall and start over or should I dissect it until I find the issue? I have tried both, and with my level of experience, they are both time consuming and challenging…I’d appreciate any recommendations you might have.

Well, at least that was much simpler than I was expecting from your original post. Glad that’s sorted.

As for fixing the problems with your model, there isn’t a one click fix. You can select the incorrectly oriented faces and then right click on one and choose Reverse faces. You’ll then need to reapply textures that were applied to the back faces. Nothing will be fast about it, though.

How is the model to be used? Will you need to be using this same model throughout your coursework? Or is this a one-off thing and you’ll be moving on to another project? Although going through and fixing things would make a good learning experience regarding the use of SketchUp, I’m wondering if you might do better to let this one stand and make the next one better.

Ya, sorry….I have a hard time explaining things I don’t fully understand. I really appreciate your help. I just have to make this work to do a fly through video right now, but I think I will redo it when I have some time.

1 Like