Sketch up messes with my Mac suddenly

I am suddenly experiencing issues with certain/many commands in Sketch Up that sort of “locks” my computer. I am working on a file and wants ie to add a texture. Then suddenly all freezes, SU shuts down, and keeps being irresponsive. The only way to make it work again, is to reinstall from timemachine an hour prior to problem… It started yesterday after an update with Safari 16.3 that I have rolled back with timemachine - but can that be the issue??

Share the SketchUp file so we can see what you are working with. Are you still using SketchUp 2021 and Big Sur as indicated in your profile?

Hi Dave - you´ve helped me before :slightly_smiling_face: I am using 2022 pro and has Monterey 12.6.3.
Here is a link to the file WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free
But it happens on 3 different files out of the blue…

1 Like
sorry - here is link

I thought it was you. :slight_smile:

It might have something to do with the Safari update but I’m guessing it has more to do with reaching the tipping point in your file as far as geometry and file size. I fixed incorrect tag usage, purged unused stuff and reduced the size of the largest 17 materials to something more reasonable. See if this file works any better for you.

You might want to upgrade to SketchUp 2023.

Wauw! You are my hero! I will try it out and get 2023 asap. I will let you know what happens. Thanks

1 Like

It worked a little and then it happened again when I tried to use “lones fliser” in colors. When I ask that command everything stops and I have the wheel and can only force quit. And after that happens my mac does not recognize Sketch Up anymore and I need to roll back from timemachine to before it happened…?

1 Like

even my wacom pen stops working?

Does this make any sense to you?

I think I can read Norwegian more easily than that. :smiley: I wonder if @colin has any thoughts.

haha :slight_smile:

Did you actually get a Bug Splat message and did you send it in with something that Colin could use to identify it came from you?

I did get several but I am affraid I didn´t identify myself… I will next time.

Please do so that can get identified.

Just did so

1 Like

It got number #158142

1 Like

Now we wait until @colin has time to look and report.

Great - thx again

1 Like

There is a problem where adding materials to a model that has a lot of materials already, can take a very long time. The problem doesn’t happen if Colors is set to anything other than Colors in Model.

Next time you have the same problem, before involving Time Machine, see if Colors was set to Colors in Model. If it was, change it to anything else, and try the same action again.

I couldn’t get your file to misbehave, so it may be a different problem.

Hi Colin
Thanks. But the problem came when I changed from Colors in Model to another (perhaps one of my own) group in color. Then everything crashed. But perhaps my computer is the issue…