Skelion Not accepting numeric input

Hey there everyone,

I am currently using Skelion plugin for solar panels and solar system design, it was working perfectly but now for some reason it is giving me an error every time I want to write a number as a tilt angle, and it is asking me to use (.) as a decimal mark!!

Anyone faced this problem before?

Well some countries use a comma , some a dot .
Usually softwares use the decimal symbol of the OS, or can be forced.

Seems like Skelion might have been hard-coded to use a dot . as a decimal symbol. If so, not much can be done. Have you contacted the dev to inform them ?

Thank you so much for replying

I haven’t yet contacted anyone, I have tried (,) and (.) still the same error message
and it wasn’t like that before, it just stopped accepting any numerical input.

Presumably you are using SketchUp 2021 Pro since there is no free version of it as your profile shows. So, SketchUp 2021 hasn’t changed in nearly two years and from what I can see on the Skelion site, it hasn’t changed in months. So what changed on your computer after Skelion last worked correctly?

Check Num lock or Caps lock.

Yes I am using Sketchup Pro 2021, and nothing has changed actually
and that is why I am confused about this situation
especially that my team is using the same software, two of three computers are facing the same problem, one of them is working just fine!!

I have checked, both are not relevant to what I am facing

Please correct your forum profile.

Something has changed. You said so yourself. It used to work and recently quit working.

So the thing to do is figure out what is different between the computers. This is basic troubleshooting technique.

do they have the same decimal preferences ?

shooting in the dark here, but that would explain.