SKB filenames changed?


#1

Did the naming system for backup files change with this new update? I now have two files in every folder that look identical unless I look at the file’s properties to determine which is an .skp, and which is an .skb.

I could be wrong but didn’t sketchup previously name the automatically generated backup files “backup of [filename]”? Layout still names them that way.

The combination of this issue, and the open as read-only issue has made for a frustrating day or two at my desk. I thought I had lost hours of work, only to discover that I had been editing the .skb file instead of the .skp file since they both look identical in my folders now.


#2

The naming system has not changed.
By default the .skb files should display a blank icon as they aren’t linked to SketchUp - you might have linked them yourself.

I want to know what I am dealing with, so I always remove the tick in Folder Options that hides file extensions.

So my backup files don’t carry the SketchUp icon, and the extension is visible, and double-clicking on them only brings up the Open With… dialog.

Anssi


#3

here’s what I see. I didn’t change any settings, but this change is universal across all of my jobs.

I must have opened an .skb file and had it associate with sketchup.

Is there an easy way to revert this?


#4

this topic can be deleted as it is a user-error/windows situation and not related to sketchup.