Feature request - Different file icon for backupfiles. they look too similar to SKP files in finder window

Please make SKB backup file icons clearly different from SketchUp file icons. Yes, I know one has a square, and the other has a page (sure… Ok). Yes, I know I can see if the file extension in the detail view. But it just seems like bad UI design to have them look so similar. If you were to show somone who didnt know the two icons side by side with no other details. I’d be willing to bet not many people would be able to correctly guess which file is the back up file, and which one is the SketchUp File.

Have you linked the SKB file type to SketchUp? It should not be linked to anything, and show a generic file icon. (assuming you talk about the Windows OS as in your profile, not the Mac as in your mention of Finder)


in addition to what Anssi said, I believe that, at some point, you chose to open a .skb file directly by picking “open with”, and windows remembered your choice.

It is best renaming your .skb files into .skp when needed before opening them.

There’s no simple way to unlink a filetype from a software in windows(again, assuming you’re on windows as your profile says), except by assigning it to another software, but here is a workaround if it really troubles you (you could also uninstall/reinstall sketchup) :

  • Make sure you can see file extensions - In Windows File Explorer, on the View Ribbon check the ‘File Name Extensions’ box
  • Close Windows File Explorer
  • On your Desktop, right click and select ‘New’ - Text Document
  • Name the file xxx.bat - make sure to remove the .txt and replace it with .bat
  • Right click any …old file, select ‘Open With’ - Choose Another App’
  • IMPORTANT - Check the box marked ‘Always use this app to open .old files’
  • Scroll to to bottom of the list, click ‘Choose another App’
  • Scroll to the bottom of this list and select ‘Look for another app on this PC’
  • Navigate to the file you created on your Desktop (xxx.bat) and click open
  • You will probably get an error trying to open the file - this is OK
  • IMPORTANT - Delete xxx.bat from your desktop

Now the file association will be set back to unknown .

1 Like

If you are using Windows, you can just hide your .skb files in any Folder by creating a .bat file that hides them for you. When you want to access the hidden .skb files, check the ‘View>Hidden Items’ box in the Folder.

To create the .bat file, first create a new text document (.txt) by right clicking inside the Folder, then New>Text Document. Right click, edit, add the following line:

attrib +h *.skb

Save this file, then rename it as a .bat file. Call it something like hide.bat so you know what it is. Double click on it to run it. Your .skb files should disappear. If they don’t, check whether the ‘View>Hidden Items box is checked in the folder. If it is, uncheck it. Keep this box unchecked, and you will not see your .skb files.

If you don’t want to automatically hide the .skb files anymore, change the ‘plus’ to a ‘minus’ and run the .bat again.

That’s what I do. I find it helps with the clutter.

1 Like