When I rename skb to skp nothing happens

Iam working on a project that i want to go back to a point but when I try to rename the skb to skp nothing happens, the icon stills blank and doesnt transform in the skp file.

Please somebody helps, its veeeery important to me.
Thank you

Have you tried opening the file after renaming it?

What version of SketchUp are you using? Please complete your profile.

Your Windows File-Options must be set to display the file-type extension, otherwise you’ll just change the file’s name, BUT its file-type will be unchanged…
For example…
If the file-types are not shown…
Your model MyModel shows as a SketchUp [.SKP] file.
Its backup-file is also called MyModel and shows as a SketchUp [.SKB] file.
The displayed names are the same !
Rename the MyModel SKB as MyModel.skp. and it will leave it as a SKB file !!
Its actual name is now MyModel.skp.skb !!!

So set the File-Options to show the file-type and ensure that you change it at the very end of the whole-name…
Note:- in Win10 it is accessible in a Windows Explorer dialog > View > File Name Extensions [check-box]
You will be warned about changing the .SKB to .SKP… but do it anyway…

Thank you very much sir!!!

It’s worth noting that you can open .skb from within sketchup, therefore not needing to change the file extension.

1 Like

I hadn’t tried that, it does work, but you would need to switch from SKP to All Files, for the SKB to be listed.

1 Like

I’m sure that used to be in the help files as the correct way to to access a backup file.