Single click to select?

I just loaded Pro onto a new computer and the program is requiring me to click an entity twice to select it.

Is this a setting within the program or should I be looking at my mouse settings?

Normally a single left click is used to select a single entity. A double left click on an will select a face and it’s bounding edges. Double click with also open a component or group for editing. Triple left click selects all attached geometry. Do you have access to another mouse to see if it is the mouse that is failing?

Select Tool - by ‘click’.
One click selects the object below the cursor - be it face, edge, curve, container [group/component/image], text, dim etc.
Two clicks - if the object is a face it selects that face AND its edges; if it’s an edge it selects all faces attached to that edge; if it’s a group/component etc then it opens it for editing.
Three clicks - if the object is a face or an edge then it selects ALL connected geometry [edges AND faces]; if it’s a container - group/component etc - then it opens and selects all geometry connected to that part below the initial cursor-click [i.e. as if you had edited the container with a double-click and then treble-clicked on the face afterwards]

Select Tool by ‘fence’ - drag the corners right>left to select everything inside the fence; or left>right to select only everything that is entirely within the fence [overlaps are ignored]

To add to a selection hold Ctrl and select, to remove from a selection hold Ctrl+Shift and select, to toggle selection hold Shift and select…

One click is not doing anything.

I have to click twice to select any object.

I tried another mouse and the touch pad and its the same issue.

It’s almost like the program reaction is one click behind what I am trying to do.

Since this doesn’t happen to SketchUp on any computer I have seen, I would strongly suspect some aspect of system or mouse configuration on your new computer. You have tried another mouse and it also affects the touchpad, so that would narrow it down to a system setting that affects all cursor-control (mouse-like) devices.

Your profile doesn’t say what version of Windows you have on the new computer. I’m on a Mac, but with that added info one of the Windows gurus may be able to help you.

If you do what it takes to get one entity selected, and you then single click on another entity, does the first one get deselected? Do both end up being selected, or just the second one (or none)?

Could also be a graphics card issue, but as you only have “yes” it’s hard to know.
Try turning off hardware acceleration in Window/Preferences/OpenGL
and check that your windows updates are all done and your graphic driver is up to date.
If it’s Windows 10 it could be anything.


As recommended I turned off hardware acceleration and the single click works correctly.

I will update my graphics driver.

For reference I am on a HP Pavilion w/ Windows 7 64-bit and a Radeon HD 6770M graphics card.

Thanks everyone. Much appreciated.

Can you put that info into your profile so we don’t have to look for this thread again next time we want to see what your setup is.

Just for interest you could change the preferences again to bring back the problem, then single click on a face and delete it. I think it will delete ok. The only issue was that you were not able to see that the face was selected. The double-click also selected the edge, which then at least looks selected even if the face doesn’t.

Hi All,

I am having a similar problem and cant seem to figure it out.
So I have sketch up pro 17 on a surface pro which I have been using with no problems for the last couple of years until today.
I also have a new laptop with 17 installed and its the first time I am using it.
I have tried two different mouse]and both the touch pads on the laptop and surface pro-nothing happens.
If I click to select a surface it does not highlight as selected, if I double click it selects everything, surface and connected edges and connected faces.
Both laptop and surface pro are windows 10.
Any help would be appreciated.

Since SketchUp 2017 Make hasn’t changed since, well, 2017, you need to look at what has changed. Most likely this is GPU related. In SketchUp, go to Window>Preferences>OpenGL. Untick the box for Use Fast Feedback. Any improvement?

You should also go to the manufacturer’s website and make sure you have or install their latest drivers. Don’t let Windows tell you if the drivers are up to date. They push their own modified drivers which more often than not break things.

Thanks DaveR, same happens when I untick the box, ill double check the drivers now.

Also make sure you have installed SketchUp correctly. That I, you right clicked on the installer and chose Run as administrator.

Thanks DaveR-re installed and all working ok thanks for your help :smiley:

1 Like

Thank you, DaveR. I was suffering with my multiple clicks and now everything is fine again. Great!

1 Like