Select one face after entering solid group

I have a solid group.
I double click on the solid group in order to edit one face.
I single click on one face in order to select that face.

Everything is selected. It’s as if I have clicked ctrl+a instead of single-clicking on one face.

This only happens if I do it quickly. If I double-click on the solid group, wait a second, then single click on the face, then it only selects the one face.

But when I do it quickly, it selects everything instead of just the one face.

Is there something I can do differently, aside from waiting this extra second? Thanks.

It does sound as if you are clicking too quickly. A Triple click with Select opens the object for editing and selects all connected geometry. Either slow down and give a break between the double click and single click or right click on the group and choose Edit Group. Then single click on the face. You could also set up a keyboard shortcut for Edit Group but you’d have to single click to select the group first.

It shouldn’t take a full second delay between clicks.

I didn’t time a full second, there is just an extra beat that I have to wait. I was hoping there would be a setting I could change so that I wouldn’t have to intentionally slow down.

You could play with the double click speed for your mouse but there’s no setting in SketchUp that you can make to change this.

I hadn’t thought of a keyboard shortcut. I guess W isn’t assigned to anything. That would probably balance the work between the two hands and allow me to work as fast as I can. Thanks.

Enter is the default.


Oh I didn’t know that! Thanks