Changes not mirrored when editing duplicated component

Following along with a tutorial on youtube, earlier i was able to move an item, press ctrl and move the duplicate of the item, afterwards when editing it, the original was also edited but now I can’t seem to get this to happen.

If anyone knows why this is it would be greatly appreciated.


It would help if you’d share the .skp file so we can see your model and help you identify what’s going on.

The two most common reasons seem to be using groups instead of components or opening the component for editing and copying the geometry instead of copying the component itself. This second one can be identified by a larger bounding box surround both lumps of geometry.

Cheers DaveR,

You’re right I was triple clicking then moving, i just tried one click, then move and it worked. Don’t think i fully understand the difference between multiple clicks.


A single click selects the object (component or group) or the entity (edge, faces, guideline, etc.) that you click on.

Double click on a face selects the face and its bounding edges. Double click on a group or component selects the object and opens it for editing.

Triplle click on a face or edge selects all connected geometry. Triple click on a component or group opens the object for editing AND selects all the connected geometry.

That’s helpful, appreciate that!

1 Like

…and 4 clicks makes coffee.

not really :cry:

LOL! If only.


1 Like

SketchUp SuperPro Edition, comes with coffee extension preloaded.

1 Like

I didn’t even know that version was brewing!

1 Like