Component copies don't mirror changes


#1

I’ve tried this a number of ways, and I even uninstalled Sketchup 2015 and reinstalled it, restarting my computer in between to see if it would fix my problem. It used to work, but not now. I make a window shape, make it into a component, copy it to another location on the same plane. Then I select the initial window shape by double clicking to edit the component. I draw a line or do anything else to it, but the copy doesn’t mimic what I’ve done. I don’t get it. What could I be doing wrong? It also doesn’t ‘cut’ into the wall surface when I tell it to, and sometimes when I double click it doesn’t go into component mode. Very strange.


#2

It sounds to me as if you’ve made a group instead of a component. We could answer definitively if you could share a sample SKP file that exhibits this behavior.


#3

It does, but I clicked “Make Component”, and glued to “Any”, “Cut opening”, etc. Attached is an example. Thank you for your help!TestFile.skp (72.6 KB)


#4

A gluing-behavior component must have its ‘blue’ axis perpendicular to the face onto which it will be placed.
It will then glue onto that face as hoped.
If it also has cutting-behavior set, then it will cut a hole in that face.
Also be sure that the blue-axis is perpendicular to the font of the face - NOT the back-side - this IS important.

It’s best to do this axes set up as you create the component: however, you can select an instance and use the context-menu to ‘Reset Axes’.
Any repaired existing instances will still not ‘cut’, but any new ones you place onto faces should now glue and cut as you hope…


#5

It looks that there is only one component. Take a look with Outliner (Windows > Outliner).

So perhaps you opened the component to edit mode before copy?

Activate the component with one click only, make a copy and then it should work. Double click will get you to edit mode.


#6

I don’t know. I can’t open that file now - it says it is locked by another user and is read only (?) Anyway, maybe I’m opening the components the wrong way? It looks like if I click or double click from Outliner, it’ll do what I want. If I try to open by clicking on the instance, it doesn’t work. Weird…

Not sure about the blue axis perpendicular to the face, etc, but I’ll play around with that and see where I land.

Thank you all!


#7

Yes, Outliner helps when working with components. Clicks/double-clicks should of course work the same way in model as in Outliner…

For “Locked by another user” you can find some info from this forum… like this:


#8

Seeing it in action :wink:

I used the move modifier Ctrl (Microsoft Windows) or Option (Mac OS X) to move a copy to the second location - http://help.sketchup.com/en/article/94866


#9

The issue is a typical mistake by new users. You made a component of the “window” on the left but then you opened the component and copied geometry over to the right to make the second one.

For these screen shots I deleted your walls so it’s only the windows we’re looking at. You can see the blue bounding box encompasses both of your windows.

With the component open for editing you can see that all of the edges and faces can be selected.

In the GIF that Chris posted, you can see that he did not open the first window for editing before copying. He simply selected the component and made a copy of it.


#10

Thank you all! This BB is a tremendous resource. You’ve all given me a lot to play with. Unfortunately, I also have to work for a living, so I can’t grind up all my time learning skp! But, it’s coming. I appreciate your help.