Problems editing a copied component


I am wondering if anyone else is running into this problem.

(Running SketchUp 2016 on Mac with El Capitan OSX 10.11.3)

I am modeling a table. I make the basic components, copy them and position them in the model. The issue I am having is when I make a copy of a component(a table leg in this case), to add details that should then be transposed to the other components in the model.

This is what I do. Make a copy of the component and drag it outside the model so I can work on it. I use the original component that the others were copied from. I highlight the copied component and “explode” it to loose(ungrouped) geometry. I make the changes I want to see on all of the components in the model. I highlight it again, right click and “make a component”. I assign it the same name as when I made the original and click ok. I get the warning that the name already exists and that the changes will be transposed to the originals(which is exactly what I want), I hit “replace”. “Replace selection with component” is checked in the dialogue box throughout.

The problem is that the reworked component does not become a component again(it remains as loose, ungrouped geometry) and none of the changes I have made are transposed to the components in the model.

I have tried saving the model, closing SketchUp, restarting my computer and attempting the operation again to no avail.

Any thoughts?


When you explode the component, it loses any references to the original. Double-click the component to “open” it for editing … any changes will be reflected in all the other instances. When you’re done, click outside the component bounding box to “close” the component (or hit the ESC key).

1 Like

I’m on the same versions of SU and OS X as you list. If I follow the workflow you describe, I get the result you expected not what you observed. That is, when I copy, explode, edit, re-generate component with same name, and click “replace” on the warning dialog, the other pre-existing copies are also changed. So I don’t know what is happening in your specific case. Can you upload your model so we can check if there is something special to it?

That said, @jimhami42 is right on the money about your workflow. You should open the copied component for edit, not explode and regenerate. Doing it your way just adds extra steps and risks errors.

1 Like

I wonder if there is an issue with the individual file of mine, since you were able to achieve the desired result. I am following a step-by-step exercize from the book “Woodworkers Guide SketchUp”, by Bob Lang(I am an aspiring novice at SU). Based on your input I got an idea for a work around that did not involve exploding the component in question(just editing, as you suggested), and it seems just as easy and efficient as the original technique.

Thanks for you help.

Does Bob really teach the explode and remake method you describe?

Yes. It is how he(in the book, at least), teaches how to make quick and accurate mortise and tenon joinery.

This is all fairly new to me. What are the issues with using this method?

Interesting. I have a different method for that.

There are several issue I can see but here’s one. Suppose you draw an apron between table legs without the tenons and you make the apron a component. Then drag a copy of the apron component away from the model, explode it and add the tenons. After remaking the component and choosing to replace the originals with the new one, the aprons already in place in the model will get shifted because of the axis location unless you also make sure to place the new component’s axes in the right place. If the component had been rotated at some point before you explode and remake it, the replacements will be positioned incorrectly, too.

Screen shots to illustrate:

Legs and apron components.

Front apron copied out in front of the table and exploded. Tenons added.

Ready to make component with the same name as the original.

After clicking on Create and choosing to replace the original components with the new one.

The origin of the component’s axes is the insertion point for the component. That can be leveraged in useful ways but in this case, it would be making you work harder.

If I had just edited the copy of the apron component without exploding it, the ones in the table model would get the tenons AND they’d still be in the right location.

If the overall size of the component won’t change as in cutting the mortises on the legs, the explode and remake process can work but it’s not very efficient,


In the model I made using Bob Lang’s approach the simple legs and aprons are in their correct position and are components. Tenons are added to the aprons by copying and editing the component so that changes are consistent throughout. The explode method comes in when creating the mortises. A leg and 2 adjoining aprons(all components), are selected, copied and dragged away from the main model to work on. While still selected all of the geometry is exploded. All of the apron geometry is erase up to the face that intersects with the leg. This, in effect, leaves a perfectly placed mortise in the leg. At this point the loose geometry of the leg is all selected, made back into a component and given the same name it had, prompting the Replace window.

This is where my issue was, in that the copied and altered leg could or would not become a component again(it just remained as loose geometry) and none of the changes were transposed to the legs in the model. At this point I’m wondering if there is an issue with my file. I’m going to try to rebuild the model from scratch with a new file and see if this is the case. The upside of all of this is that I’ve become quite good at creating this model.

Perhaps you could share the model?

It sounds like a lot of steps to create a couple of mortises, though. I use what for me is a much simpler method.

Extra leg component in the background to make it easier for you to see what’s happening. I wouldn’t make that extra copy normally.

There are some cases in which I would use the geometry from one part to create the mating part but I still wouldn’t use the explode and remake process for that.

Practice makes perfect. :slight_smile:

1 Like

I am having the same issue as @jgwilson1025

I made the leg, aprons, tenon all as components. Copied the original leg, aprons and reduced to just a leg+mortises. Made those exploded parts back into a component to replace the original component. The real legs weren’t updated.

I think you have a misunderstanding of the fundmentals of using components. If you explode a component you basically remove any connection that geometry had to the geometry in other instances of the component.

I’d be interested to see your model and to try to understand exactly what you were trying to accomplish with the process you used. I’d stake my lunch that there’s an easier way to do it without exploding anything.

When you made the exploded geometry back into a component, were you careful to give the new definition exactly the same name as the original?

Aside from that, the tenons should be part of the apron component’s geometry, not a separate component or nested component of their own. That could also be part of your problem.

Hi Steve,

Yes, I was quite careful to do as you say. I’ve attached my model.

table2.skp (61.5 KB)

Hi Dave,

I’m following the instructions in the SketchUpForWoodWorkers doc, in which he says to explode a copy, remove all but the mortise (bits of the tenon), then make that back into a component that replaces the original.

I attached my model just now in a reply to Steve.

Hmm… Since I can’t peer over your shoulder, I can’t say exactly where you went wrong, but I opened your model, selected all the loose geometry off to the right (the exploded and edited leg), made it a component named “Leg” (note: the capital L is important), said yes to replace, and here’s what resulted:

That’s a very strange way to go about it but then that guy has some other weird methods, too.

1 Like

Hmm, I tried this again and see a more specific issue. If I select the “extra” leg parts and make a component named “Leg” (respecting case) it doesn’t actually make a component. If I name it something else it does make a component. This is true even though I select Replace in the dialog about overwriting the existing “Leg” component.

Why would that be?

Perhaps you could share the SKP file?

Also check your PMs. Click on the L in the green circle in the upper right of the forum screen.

I just noticed that your profile says you are running macOS Sierra? If so, I wonder if this is an OS compatibility bug rearing its head.

Yes, it could be.