Since updating Sketchup my model has wavy faces

Here is a screen shot of a model I am working on. Mac OS, SketchUp 20.1.228.

Looks like you have Z-fighting caused by multiple faces share the same location. Upload the file so we can see what you have exactly.

Here is the fileBedroom Dresser.skp (29.1 KB)

Actually, the problem is due to the extreme distance between model and camera. This sometimes happens when people model with the Camera set to Parallel Projection. Do your modeling with the camera set toPerspective and then use Zoom Extents to bring the camera close enough to see the model.

Leave Parallel Projection for display/image export and do your modeling in Perspective. That’s the way SketchUp was designed to be used.

Notice the camera’s coordinates in the model when it is first opened. Just the X value is over 101,000

Switch to Perspective and Zoom Extents. Then back out a little to make similar view. X is no down to 104-ish.

Wow, I’ve been using SketchUp for years and, because I am using it for woodworking and I need to see details for small dimensions, I have always set the Camera to Parallel Projection. This is the first time I have had a problem with that.

Sounds like you’ve been lucky. Most of my SketchUp models are woodworking projects. I always model in Perspective and only use Parallel Projection for 2D views that I dimension in LO. I’ve never had any problem seeing small details when I need to.

Thank you. I will start working that way and learn as I go.


You can change the amount of perspective effect by using the Field of View setting. You can even set it to almost-parallel, which is 1degree.
Try out different settings to get one you like.

Thanks again, I will try that. I also found an interesting note about how to prevent “Cliping.”

This behavior has changed in 2020.1
‘Zooming’ (scrolling with middle wheel) now positions the camera.