[Simlab Importers] Importing dwg and Step files

dwg
import
step

#1

Not able to import .dwg files or .STEP files into sketchup 2017. they were working fine (same drawings) on 2015-16.

I have been in touch with Simlab numerous times, sent them the STEP file and it loaded on their 2017 version. what am I missing, as I am sure it must be operator error. (I’m not too bright)


#2

Can you provide more information on why you can’t import those files? Do you get an error or don’t see such options etc.?

Did you try this plugin for .step files: SimLab Step Importer for SU


#3

When I go to the file menu for import the pop up menu for file location comes up. I select the autocad .dwg file and click options. I check coplanar faces etc. then import. An import results window show up giving me a summary of the imported entities. I close that window and the program just sits with the blue circle going round and round and round and well you get the rest…

As for the STEP files. I paid for the simlab Step plugin which has worked in the past on all of my other versions of sketchup. However this time it will not import my 3D STEP files. I have sent numerous emails to simlab (they are very patient). I sent them the STEP file and it worked on their computer. I sent them a step by step process with screen shots. sent them the preferences menu showing the program is enabled. still not loading the drawings.

Again I’m not too bright so I’m sure its me and something Im doing. I purchased a new Alienware computer to allow for better graphics and speed but so far sketchup has been a struggle since I loaded it on this computer 2 months ago


#4

check content and validity of the DWG with free ‘Teigha Viewer’, down-save to R2000 and try to import in SU again.

check content and validity of the STEP with free IDA-STEP viewer.

If you need to handle with NURBS surfaces/solids from STEP/SAT/IGES files constantly you might want use a 3D NURBS modeler with a native STEP/SAT/IGES import/export which avoids the need to tesselate to facettes for a use in SU.


#5

Thank you Sketch3d- everything you printed above is a foreign language to me. I guess my biggest apprehension to doing what you suggested is why do I need to pay for more plugins and add on’s for something that should already be part of the software package I’ve paid for and has worked right up to the time I switch laptops and upgraded to 2017?


#6

DWG import/export in general works, STEP import is not part of the SU functionality.


#7

That’s correct, that’s why I paid for it from simlab


#8

How long did you wait before giving up and killing SketchUp? There is a follow-up phase during which SketchUp converts the imported geometry into its own internal representation and does cross-checks to deal with things such as duplicated vertices, coplanar faces, etc. That stage can take a long time - hours even for a complex dwg. I can’t explain why SU 2017 would take longer than previous versions, but you should at least give it chance.

The STEP importer is not a Trimble SketchUp product; simlab is not owned by Trimble or part of SketchUp. Unless the import is causing SketchUp to crash, there really isn’t much Trimble can do to help you. That’s not to say that no aspect of SketchUp 2017 could possibly be to blame, rather that it is up to simlab to diagnose why their plugin is misbehaving.


#9

Slbaumgatner: - I clicked the import tab and went to a meeting this morning at 8:45. I just returned now at 9:50 and it was still processing (blue circle). I closed it out. The Autocad import was just a 2d shop floor layout not even a 3d rendering. Something in the program is not connecting the dots.

Yes, I’m not putting the ownership on Trimble regarding the STEP file loading. I think it is more me and either not placing the STEP exec file in the right location for sketchup to see it or not having the preferences set up correctly? Since simlab was able to get my drawing to load in their test file, I would say the program does work with sketchup 2017 but something is missing on my end. I’m hoping someone on this forum is or was a naive as myself and found a fix.


#10

why not checking whats up by doing what I have already elaborated above… and if downloading/installing the free ‘Theigha Viewer’ is to complex just upload here or to a cloud service… besides being confi.


#11

Thank you I will
However sketch up should import those cad files that I already have imported in the past without issue. These particular files I have loaded in the past on other versions which is why I’ve chosen them now to test 2017, and they have loaded on other peoples SU without issue. I’m hoping someone else had this issue and will say I need to move the exe. file over to another location or check a box in preference that I missed etc.
I not inclined to believe it is a SU problem nor a file problem but an operator problem.


#12

What did you have configured for the DWG/DXF import options?:

https://help.sketchup.com/images/su-3000165-import-options-1.png

For testing disable all options and configure Meter (or Foot) as unit.


#13

long delay since I last posted this, was off shore for a while. Back now and attempted to import a 2D CAD file and SU 2017 is still not allowing it to import. Tried disabling all the options and still not responding.

screen shots show it went through the motions then nothing


#14

This topic was automatically closed after 91 days. New replies are no longer allowed.