Signing in Sefaira Plugin for SketchUp

This is my first time using Sefaira.

I have downloaded the plug-in and installed the extension to SketchUp. Once I open Sefaira in SketchUp, it loads and I have to sign in. I have tried both signing in with Google and with my email address, but each one of them comes back with a different error.


“This browser or app may not be secure.
Try using a different browser. If you’re already using a supported browser, you can refresh your screen and try again to sign in.”

I have tried other solutions mentioned in this forum but none of them seems to work (reinstalled IE11, cleared settings, set IE to my default browser, enabled JavaScript, etc.)

Email address:

I type in my address, don’t get the email. When I ask for it to be resent, I do get the confirmation email and everything seems fine, but nothing happens after I successfully activate the account through the link that I’m sent:

Screenshot (117)
(screenshot from Chrome browser)

Any suggestions will be appreciated. Thanks!

1 Like

After going through the steps to make an account, you can test that it works by signing into If that does work, now open SketchUp, open Sefaira, and sign in again with the same details.

Hi Colin,

Thanks for your reply! I already had an account with Trimble and was signed in to through all of that process. However, it is true that if I try to edit my Trimble profile, it does send me into the same loop but on the browser - the screenshot shows the message that I get after activating the account, and when I click on the link to log in, it goes back to the screen saying: “Your Trimble account is nearly ready. Please click the link in your email to activate the account.” Again, no confirmation email until I ask for it to be re-sent.

Screenshot (117)

I have a theory that some of our emails include a redirect link in them, and that’s what triggers spam filters. For example, if you’re trying to sign into and have to do a forgot password, the link you get takes you to the reset password page, and also knows enough to take you to your original destination, which was the sign in part of I have been on the phone with people and heard them describe the steps they were taking, and no email would arrive. Then, when I opened an incognito window and tried to sign in as them, and do the forgot password, they get the email right away.

In your case I think the request to resend gives you a less complex link in the email, and it gets past the spam filters.

1 Like

Having read your comment, I tried signing in on an incognito window, but the same thing happens - I only get the resent email, and back on the loop. I guess that it is because I need to activate the account that I don’t get to do the forgot password. However, I am able to sign in using Google on the browser Chrome, something that I can’t when I’m on SketchUp.

I have also checked my spam tray just in case but there is nothing there.

I gave a try to a different browser - Internet Explorer, since I read it’s the default one for SketchUp. An error came up saying that my account had not been verified and to please use the link on the confirmation email that I had been sent (which again, I didn’t receive). However, this time there was a “Forgot my password” link that I could click, which also verified my account, solving this whole issue.

I went straight to SketchUp to see if it worked there too, and it did! So now I can use Sefaira.

Thanks for your help!

Thanks for being persistent!