Sefaira in Sketchup - blank log in form

Sketchup 2020, current version of Sefaira. Open sketchup, Show Sefaira Plugin, The Trimble sign in screen appears but no form fields.


Windows 10. I have deleted the cache in IE. I can log into the trimble/sefaira website directly in IE and Edge.

I contacted the Sefaira support team 2 days ago and have not gotten a response. Please help.


Thanks for reaching out. The error you are seeing here has got to do with how Sefaira is interfacing with internet explorer on your machine. Could you please run the registry file linked to this article and see if that solves the issue for you?

That fixed it. Thank you Niraj.

Tried this solution, but it didn’t work for me.

Downloaded file and executed it, but still getting the same error.

Hi @AOJ,

Thanks for trying that out first. Can I ask:

  1. What version of IE you have on your machine? If it is IE 11 or later, great. Could you then clear history/cache/cookies from the browser.

  2. Second, once you do that, close SketchUp >> re-run the registry file by double clicking on it >> then open SketchUp and the Sefaira extension and see if that resolves the issue for you?

I have IE 11 and following your steps worked.

1 Like

@niraj.poudel this solution worked for me up until an hour ago. For some reason, the error has popped up again and when I retry the steps you gave, it doesn’t solve it.

Hi @AOJ,

Thanks for reaching out. It’s strange that you are not able to login again. Can you share a screenshot of what you see when you get to the login page?

Also, did anything change in your machine between now and last when you were able to login successfully?

My colleague was able to figure out a fix that has worked consistently the last few days.

It is change the last digit of the script from the article referenced above 9 instead of 8.

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION]


Why did this work better?

Hi @AOJ,

That’s great to hear. I am actually not sure why that would work better. I’ll have to ask our development team to understand what might be going on.

But yeah good to hear that you are up and running now.

I’m having the same issues on my MacBook, please help!

Hi @GabZav, could you please share a screenshot of what you see? Without which I would not know where to start.

Hello! I was having a blank window when I tried opening the sefaira plugin. However, after restarting my SketchUp the issue seemed to be solved. Thank you anyway!

1 Like

You asked over two weeks ago, but in case it’s useful, here’s what Microsoft say:

|11001 (0x2AF9|Internet Explorer 11. Webpages are displayed in IE11 edge mode, regardless of the declared !DOCTYPE directive. Failing to declare a !DOCTYPE directive causes the page to load in Quirks.|

|11000 (0x2AF8)|IE11. Webpages containing standards-based !DOCTYPE directives are displayed in IE11 edge mode. Default value for IE11.|

I had to read up on Quirks mode, but it seems to relate to ancient browser support. One thing I found is that DOCTYPE being uppercase can matter, and the Sefaira sign in window uses lowercase, but then so does the SketchUp sign in window.

Anyway, the ‘9’ variation may just be an extra level of safety to make sure it’s compatible.

@niraj.poudel didn’t report back, but maybe he can check if what I found makes any sense.