Signin Error

Thank you for continuing to work on this. No dice in Firefox even though everything (including popups and cookies) is allowed.

Make sure you do not see anything being blocked on the browser, see screen-shot

Please make sure no google dialogs are open/hidden behind the browser.

Unfortunately still having the issue.
Pupups are unblocked, cookies are allowed.

I’ve tried multiple student accounts, multiple browsers including chrome in guest mode.
We’ve tried multiple internet connections as well. The exact same “Are you in the right place” error pops up

Same problem. I am a teacher and tech director so I have tried everything. I have uninstalled and reinstalled the app in google admin console and have cleared website permissions and enabled popups. I have tried all of the suggestions above and it won’t work. It does work for me (the teacher) but I am not sure why. I have been using the app for over 5 years and have never had this problem before.

What operating systems are you using? What browsers have you tried?
Did you go through this post Sign in Change for Google Users

I am using chromebooks (ChromeOS) and chrome browser. I have had an opportunity to do some testing and have narrowed down the issue to something related to either device or user settings in domain-managed devices. It may be an age restriction because the our “student” organization unit is designated with the recent (changed a year or so ago) “under 18” or child settings. If not that then it may be our web filter. There is an extension that monitors web traffic and blocks pages…maybe there is a redirect that is being blocked? It is a web-based DNS filter, not proxy.

I tried logging in as a non-student and was able to get the final redirect to go through after approving pop-ups. But on the same device logged in as a student it gives me the option to sign in and the first popup works but then goes to the error screen. I think maybe that final redirect before authenticating is being blocked by the filter. If I go through the steps to sign in with pop-ups blocked, it never gets to the page that has the pop-up blocked icon. So, the first thing I tried was to manually approve in the site settings but that didn’t change anything. Still working on it…will update if I find out anything usefull

UPDATE: So, I removed the student account I was using from the “Student” OU and was able to get the app to load. There was another popup that asked for approval for google permissions that was new. Once I approved those, I was in. I am now going to move the student back into the “Student” OU and see if it still works.

CONTINUED: After moving the student back I am again stuck with no access. So, my guess is still the same…either age restriction or web filter issue.

I am now going to check to see if there are any permissions in the app that are OU specific.

Hey everybody, from Spain.
I’ve been having the same problems with my students. It seems that, clearly, it’s due to recent changes in the App or the way to include it under G-Suite (?).
I used to suffer the same trouble loop only in SOME of the computers/users at my school, which was annoying due to being happening as a deeply inconsistent error.
And it suddenly generalized.
The help provided by marwanobeidat -SketchUp Team Member- up here, though, has been OK, despite I had to research a little on how to allow pop-ups in each browser (I’ve been trying Chrome -Will have to try Chromium under Linux, actually, at school - and Firefox).
Under Chrome the process & solution were quick;
Under Firefox I was surprised, when checking, that I already had the included as an exception, allowing pop-ups for it… But it wasn’t working even though! - So: I hopefully happened to notice a small advice message in the upper part of the window, asking about letting or not a pop up by sketchup (I’m sorry I now can’t possibly tell what step of the loop I was in… This is becoming dizzyness by now).
I hope it can be of help for others, however, as it was for me to read all those messages about the same problem.
In any case, and as some already suggested, I find it extremely annoying to have to worry about these steps, that are not necessary at all with other Apps, in such an enviroment as a school, with hundreds of computers to be checked in some cases, and with the only help of kids who are learning with SketchUp but are not experienced enough so that they can manage changes in the configuration of the browser - Along that process, classes become extremely messy some times.
I’m sorry but I sincerely miss the Google SketchUp times when SketchUp was free and off-line, in comparison with the different steps suffered, up to the situation nowadays.
Also, I would call the guys at Google and at Trimble to consider - I’m having hard times to convince my colleagues at school to get involved with SketchUp when they are familiar with simpler options that I find poor in comparison with the rigourous SketchUp (all that about the fashion with 3D printing and that kind of stuff… You for sure know those Apps that draw anything almost automatically, but with poor learning about 3D design), since a problem like this with the pop ups is of no help at all.
And having to solve it computer by computer is like… er… prehistoric :wink:
In any case, thanks for your support and help, which in fact, seems to be working one way or another.

We are having the same errors at our schools. We’ve allowed pop-ups and redirects globally for

I’m running into the same issue on Chromebooks and on Windows.

When we go to Sketchup we get a page saying to Please Sign in

After Clicking “Sign in as …” The Google “Choose an Account” page pop-ups and I select my (students) Google Account.

Now I’m on this “Sign-in Error” page, if I click sign in as it goes back to the first image

It just goes in a circle, I’ve verified pop-ups are allowed, tried different computers and accounts as wells.

I have found the source of my problems. It may also help you. Our school web filter client was restricting google apps to only those approved for our domain. Once I removed that restriction, Sketchup was able to load and approve the credentials. You will still run into issues if you haven’t approved pop-ups for the website but that is an easy fix once you gain access through the filter.
Fortunately, I am a tech director as well as a teacher. So I was able to go into the school filter and remove the restriction.
Attached is a screenshot of what my filter setting looked like. Send this info to your tech person and hopefully they can at least temporarily change this (or similar) setting to give you access to the sketchup app again.


Thank you for sharing your findings.

We have the same issue at Glandorf Elementary as other schools here, and we have had this issue for a little over a week now.

My name is Joseph Potthoff and I am the Tech Support Specialist at Glandorf Elementary, which is part of the Ottawa-Glandorf Local Schools District. We have many of our computer classes between grades 6-8 that use SketchUp for Schools as part of their curriculum. Up until last week Tuesday, everyone was able to log into SketchUp for Schools with no issue. But recently we have had an issue with students getting a Sign-In Error when they try to log into or get into SketchUp for Schools so they can work on their projects. I have had entire classes of 20 students, and grades of nearly 75 students not be able to access or even log into SketchUp for Schools. This Sign-In Error just keeps having the student click their name and account, and it will continue to loop after they click on their account, instead of actually logging them into SketchUp for Schools. I have tried restarting the device, resetting the device, clearing the cache and cookies for each user, allowing pop-ups and redirects in each student’s browser. Nothing has worked. The students need to be able to get into SketchUp for Schools since much of their computer class is built around this product. Please can you help solve and fix this issue. Thank you and have a great day!

Sorry to hear that you are having difficulty @potthoff.j. I normally recommend stating off with a few basic steps but you seem to have already taken care of all of them so we can just jump ahead to some of the more advanced steps. I’ll message the rest of the team and see if they have any suggestions that might help while I dig into the database and make sure everything is working as it should on our end.

In the meantime, if you can post a screenshot of exactly what you are seeing that might give me a little more information. Additionally, if you have a custom domain you can share with me, I can take a look at the database and make sure you have permission to access the app.

Do you have any web filters?
See this response Signin Error - #36 by pvigil

Complete ■■■■ show. Everyone having the same issues logging in

Same problem for ONE student account so far for us at . Other accounts are logging in successfully (at least they were yesterday 3/6/23).

Using a Chromebook / Sign in with Google, is not able to login. He is redirected to sign-in error. All Pop Ups have been allowed for the user’s OU. We are using a G Suite for Education account. I am the administrator, and I have installed Sketchup for schools on our domain via the Google Admin Console. All other students at RITS are able to login using “Sign in with Google”.

1 Like

Following for same exact issue.