Shortcuts in SU web are not translating to french

Ok, I pretty much never use SU web, and when I do, I don’t use shortcuts. so I didn’t notice this until today.

My SU for web is in french, so is my keyboard (AZERTY), but the shortcuts are in QWERTY mode :

if I hoover on the circle tool, it tells me to press C as a shortcut. Fine.
if I hoover on the rotation tool, it tells me Q however if I press Q, I get the 2 point arc tool.
if I hoover on the 2 point arc tool, it tells A, and when I press A I get the rotate.
Same with move tool, it says M, but I have to press the ,? key.

thing is, on an AZERTY keyboard, some things are switched compared to a QWERTY : A and Q, M and ,?, Z and W

SU for web shows the proper shortcut in the hint, but expects me to use a QWERTY keyboard.

Tried in Safari, same thing. it expects me to be using a QWERTY layout.

Anyone with an AZERTY layout + machine can try and confirm ?

edit : tried on my PC, same deal. app thinks don’t see it as AZERTY

It does seem to read the keyboard code and not the letter you pressed.

@marwanobeidat I don’t see a bug report that exactly matches this issue. The problem, doesn’t happen with the desktop version of SketchUp.

1 Like

yep. I guess the german keyboard might have this issue too on one or two key, since they swap Z and Y.

This topic was automatically closed after 91 days. New replies are no longer allowed.