Shortcut command for undo and copy not working

I have just started using SketchUP (AutoCAD user 15yrs). It seems when I use the shortcut keys command+z
for undo, It invokes the zoom icon. When I try to copy using command+C, it invokes the circle command/icon.
I’ve tried setting my keyboard back to defaults after much research on this problem, but to no avail!

SU v17.3 had some mac Sierra fixes, v18 also fixes AA issues…


Not a mac user, but just check it isn’t meant to be Option rather than Command.

If there’s nothing to undo when you type ⌘Z, this will be read as ‘Z’ and activate the Zoom Tool. Similarly, if there’s nothing selected to copy when you type ⌘C, this gets read as ‘C’ and activates the circle tool.

This isn’t a big problem for me as undo and the clipboard were not usable at those times anyway, so it’s just a weird glitch. If this is happening for you when there is something to undo or copy then that is a problem. Open the Edit Menu. If Copy is not greyed out when you type ⌘C and this activates the circle tool, then you have a problem.

You could change the shortcuts for zoom and circle here:
to something other than ‘Z’ and ‘C’. I never use the zoom tool shortcut anyway so I could just delete that one.


Very helpful…thank you! Your solution worked when I made sure the object was selected before I used the shortcut key for zoom (BTW, were do I find the symbol for “command”?). However, short cut for copy invokes the circle command no matter what. I found a way around the copy…M+Alt works just a well.

Your description sounds the wrong way round. Select an object for copy, not zoom/undo. Anyway, it is a bug and shouldn’t be behaving like this.

It’s a bit awkward to get but once you have it, keep a copy in a text file or set a text shortcut. You could just copy this one: ⌘.

If there’s other characters you want, you can enter Unicode characters by enabling Unicode Hex Input in the menu bar. Go to System Preferences / Keyboard / Input Sources. Tick “Show input menu in menu bar”. Click ‘+’ and choose “Others”, then “Unicode Hex Input”. Now select that option in the menu bar over to the top right of your screen and you can hold option ⌥ down and type the hex code for any character you know or look up online. This should work in any application that lets you type text. Remember to change it back to your usual country or you’ll think your option key is broken.

Unicode Hex Input

Once you have the ones you want, its handy to make a shortcut in that same Keyboard preferences so you can type e.g. “uparrow” and it converts to “↑”.

⌘ is U+2318, so you’d hold option and type 2318.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.