Shift key issues in measurement input

,

Hello, I’m having the problem that when I try to type in for example, 3’, into the measurements box after I have started a line, I can type in the three no problem. But when I press the shift key the measurement box suddenly changes to the random length my curser is at. Therefore I type in 3 then when I press the shift key the 3 is gone, it now reads 4’ 5" or something then I press the ’ key and then it reads only the ’ as typed in, then I press enter and nothing happens because it only has a ’ in the measurements box. Anyone have a solution to this problem?

Dave, I think the OP must be using a keyboard that needs the shift key not for the inch symbol, but for the foot symbol - the original post shows 3’ not 3".

So it needs some different solution. No location or country code is given, and the operating system is given as iOS - on which I don’t think SU (even the web version) will run. Or maybe it will on an iPad in a browser?

You may be right. It still shouldn’t be a problem if the mouse button isn’t being held down. I’ve removed my post anyway.

This could be the problem, I have a German keyboard and unfortunately it does require the shift key to get the ’ symbol.

That should not matter. I can enter the " or ’ symbols using a shift key with German keyboard layout.

The problem you described sound me, that you are still moving your mouse while typing.
Maybe you are touching the mouse pad with your palm or if you have external mouse it is still resonating on a desk or it is broken…

Try to start a line and move your mouse to the desired line direction.
Now, release the mouse. Do not touch it anymore. Keep your hand away from the mouse. (Don’t breathe at all. :slight_smile: )
Start type the number followed by the symbol, then hit enter (Return) Make sure you are not touching the mouse pad during typing.
Does it helps?

1 Like

I guess not without being allowed to breathe :worried:

On my Chroomebook (where " and are simply ignored completely when inputing measurements in feet (and/or inches)) I found out that I need to combine:
[alt gr] plus for feet
and
[alt gr] plus [shift] plus " for inches

and [enter] at the end of my input.

This works regardless of the current unit settings.

Is this an option for you, @nettepilze ?

You could simply re-map the “ key to another, therefore negating requiring the use of shift.

I do not have any problem to use it. But the topic owner has… :wink:

You could simply re-map the “ key to another, therefore negating requiring the use of shift. Hope that helps.

What is the simple way to do that?

Thank you very much guys! I went for the remap option that Guido suggested. It took me quite awhile to figure out an app and how to use the app that could do it but it worked! For Monospace: With an app called Ukelele I could change the key that is # and shift# = ’ to ’ and shift’ = # (I hope you see what I mean) its an app that lets you add a new custom keyboard and modify any key to do what you like. Thanks again for the help!