Shapebender troubleshooting 2017


#1

I’m trying to use the shapebender plugin within Sketchup (trial, so I’m using 2017) and when I select the straight line on the red axis, I receive an error message that tells me I need to select a line on the red axis.

I’ve confirmed the axis alignment of my template line and I can’t seem to figure out why it isn’t working. Any help will be appreciated.

Thanks!


#2

Upload the SKP file so we can see exactly what you’ve got going on.


#3

Hi Dave,

Thanks for the reply. Here are two screenshots I just took. In the process, I solved my initial problem but now have a new question. I copied the object I wanted to bend, the initial (straight) line, and the destination line. I pasted them “in place” in a new document but their orientation in this document was different from the original. When I ran shapebender in this new document (according to its red axis), it ran successfully. Do you have any idea why my original model’s axis is off?

Thanks!


#4

It would be easier to tell you definitively if you’d share the SKP file. Perhaps the axes in the model were changed at some point. The component would paste into the new file such that its axes are aligned with the model axes in that new file. If the component had been rotated in the original file, it’ll still come into the new file with its axes oriented to the model axes.