Shape Bender Extension not working properly

Hello all, I just downloaded the shape bender extension today and was excited to start using, however I’m running into issues already haha! I’m trying to bend a 3d chair back structure and its warping my model into strange shapes. I have watched a couple videos on this extension and how to use properly, followed the 3 simple steps, and its not working.

Please help! Thanks

OP04.skp (1.4 MB)

It will work, I would move the arc and the straight edge closer together as their relative position effects the shape. The arrow keys also allow you to change the way the shape will be produced. I seems the green preview geometry isn’t appearing, might be an issue with your model or with shapebender and the latest SU update.

But having said all that I would use Truebend for a shape like that.
v true

1 Like

Shape Bender needs the straight line on the red axis and the target component above it. I also centered the component width equally on the red axis. I had to set the start /end of the straight line and curved line using the down arrow key. Look for the green preview then hit return.

After the Shape Bend completes it names the result Shape Bender Component which is also a single level component, so your nesting was removed.

FWIW, the straight line does not have to be on the red axis. It only has to be parallel to the red axis.

1 Like

And here’s an example of how the relationship between the straight and the curve can change the shape.

1 Like

Dave,
I stand corrected. Thanks.
Looking at the the .skp file, the straight line is indeed parallel to the red axis. Moving the component so its width is centered on the straight line, and then enter a down arrow key allowed Shape Bender to work. So there is NO need to move the line and component to ON the red axis.

But there is some issue with the model as the green preview doesn’t appear. At least not on version I downloaded and I checked with a fresh model and it does appear.

Edit, found the problem, the green preview doesn’t seem to appear because the shape is in front of the edge. Move the shape over or in line with the front edge and it shows up, so you can see that down arrow fixes it.

Thanks for everyones solutions, I actually got too frustrated trying to make shape bender work, I downloaded another extension called true bend and I was able to achieve the bend I was hoping for. I will try your suggestions to make shape bender and option for the future. Thanks again!

You mean the one I showed in the very first reply to your question.

1 Like

Yes exactly, I didn’t notice anyone had replied to this thread until just recently. thanks!