Shape Bender isn't working

Hello, I have a problem with Shape Bender that I just installed on Sketchup Pro 2019: when I have done everything well (the objects are parallel, select the object, select the line then the curve) nothing happens. attach. I have the propositions Accept, Arrow, Down, …
In the screen, it’s the moment when I have to have propositions in green
can you please help me

Bonjour, j’ai un problème concernant Shape Bender que je viens d’installer sur Sketchup Pro 2019 : lorsque j’ai tout bien fait (les objets bien parallèles, sélectionner l’objet, sélectionner la ligne puis la courbe) rien ne s’affiche. J’ai bien les propositions Accept, Arrow, Down, …
Dans le screen, c’est le moment ou je devrais avoir des propositions en vert
Pouvez vous m’aider svp

Share the actual .skip file so we can see exactly what you are working with.

1 Like

shape bender.skp (200.2 KB)

Maybe it’s not working because you have two instances of the component and are selecting both of them before starting Shape Bender. Getting rid of one instance makes it easier to select only one. I moved the line and the arc to below the component just for clarity.


Please update your forum profile. SketchUp 2019 is not SketchUp fro Schools. There is on SketchUp 2019 Pro. Please add the operating system and graphics card.

I tried deleting the 2nd instance and isn’t working
I think as you said it’s my sketchup version who is wrong…
I dont really know where found my operating system and graphics card
Thank you very much for your answers and your help!

No. It isn’t the SketchUp version. Are you following the correct steps when trying to use it?

According to the post you deleted, the OS you’re using is windows, if you press Ctrl+Alt+del and open the task manager you can check what gpu you have, go to the performance tab.

Yes. I select only the object that I want to bend,i click ont Shape Bender, i select the line of reference, then the curve, and … nothing

Nothing? or do you get a green transparent mesh somewhere?
After correctly clicking the curve you get the options you showed in your earlier screenshot, the arrow keys will change the way the shape is formed and enter will finish the action making the actual bent object appear.

You can see at the bottom right the options accept, modify, …
No green objects anywhere

And i don’t know why but i don’t have the arrow keys Start and End

What happens if you press Enter after selecting the curve?

You have an RTX 30 series, and intel integrated graphics, you can make bigger the window to se what gpu exactly you have, on the image you shared it’s not shown the entire name, it could be from 3050 up to a 3090ti.

I tried and it didn’t do anything. I also tried to press Down, Up arrow but nothing either.