Shape Bender and SU2019

@ChrisFullmer, I just had a user ask for some help with Shape Bender in SU2019. I discovered it doesn’t seem to work at all. What are the chances of an update? Thanks.

I can see where the error is arising !
In almost all of the API methods passing an argument as a vertex instead of a point is acceptable.
There seems to have been a ‘reversion’ in v2019.
The entities.add_text method expects a ‘string’ and a ‘point’ [there is a 3rd optional ‘vector’].
In @ChrisFullmer 's code he passes the ‘vertices’ of the selected line and arc to some temporary text entities - as if they were ‘points’.
This has always worked in earlier versions !

There is a fix…
If the file …/Plugins/clf_shape_bender/clf_shape_bender_data.rb is edited with a plain text editor there are four lines to tweak…
Lines# 290, 291 and 302, 303
At the end of those lines add .position [so that the vertex position [i.e. a point] is used instead of the vertex itself]
So for example:
start_label = Sketchup.active_model.entities.add_text “Start”, @line_endverts[0]
becomes
start_label = Sketchup.active_model.entities.add_text “Start”, @line_endverts[0].position
Then it should work as before.
Perhaps @ChrisFullmer can publish an updated RBZ.
Under its quoted: http://www.smustard.com/eula
Modifying it yourself, even for your own use, is disallowed ?
I think… so obviously I have not been able to check if my fix works :wink:

8 Likes

Calling all cars…
@ChrisFullmer, @thomthom, et al
This seems to be a ‘reversion’ ??
Almost all API methods should accept a SketchUp ‘vertex’ as equivalent to a SketchUp ‘point’ ???

1 Like

Hmm… it is possible there was a regression introduced when InstancePath support was added.

I logged an issue: https://github.com/SketchUp/api-issue-tracker/issues/214

I’ll escalate internally for investigation.

Yea, they often do. InputPoint is usually also implicitly converted to point3d.

1 Like

I mentioned this 3 weeks ago elsewhere.

2 Likes

I’m sure this regression will be corrected in a MR very soon…

1 Like

I imagine you’re right. Thank you.

any update on this?

Did you try installing the maintenance release of SU2019? Was there any change? If not, find the RB file in the Plugins folder and edit it as TIG described.

1 Like

Where do I go to find the maintenance release? sorry for all the questions

I gave you the link in your other thread. Didn’t you read that?

its worked thank you so much