CLF Shape bender for 2017?


#1

Is there a way to get Shape Bender to work in Make 2017, or is there an equivalent?

I’m trying to bend some 3d text around an arc and it worked for the first text but Sketchup crashes every time I’ve tried it with a second piece of text (I’m assuming that this is the part of why it says it’s not compatible with versions over 2015).


#2

It’s worked fine for me in SU2017. How big is the text you’re trying to bend? If it’s small, that might be the issue. It could also be something else in your setup.


#3

It’s my bolt project.

Right now I have it at 100x scale. “PPE” bends fine around the top half roughly 100* but trying to bend “Fastener” around the roughly 180* crashes skechup every time (well it did 3x in a row)


#4

Well crud, and this time it didn’t recover… lost anything recent I did to the bolt :-/


#5

Maybe you can share the model.


#6

Nope, if I was smart I would have saved a current copy when it recovered the first time. I didn’t. It’s gone.

Oh wow, I just checked, I guess I haven’t saved since right before I posted this morning (before I scaled everything and it worked). I guess it’s back to the drawing board. I hate when I do something stupid :-/

I guess I’ll post when I have time to make another bolt head…


#7

Well that’s weird, ever since the crashes the extensions toolbars disappeared and are not listed in the available toolbars (under view), how do I get them back?

I tried disabling them and re-enabling them and no change.

Do I have to delete the file out of the directory to remove them or is there some way to do it? I can’t figure out what the check to the left does in the extension manager either.


#8

No. You shouldn’t have to do anything to get it back. I suppose you could try the standard Windows first troubleshooting step and reboot the computer.


#9

3D text can have some surprisingly small edges and sharp corners that cause problems with operations that warp the text. But unless the Shape Bender extension is running afoul of a bug (either in its code or in SketchUp) I would expect the usual sort of holes and strange “wings” rather than an outright crash! Did you get a BugSplat (and did you send it in with info identifying you)?


#10

Can you post a screenshot? I don’t know what check you are referring to…


#11

when you click the icon on the left it turns into a checkmark. you can also check all of them or none at the top


#12

And I haven’t figured out how to get my extension toolbars back… restarting, turning them on and off… doesn’t change anything.


#13

I ended up having to unistal and re-install to ge them back. All the restarting, rebooting, even removing them and installing the extensions, removing them from the directory, replacing and re-registering them… did nothing…


#14

My guess is that SketchUp’s registry data got corrupted during the crash, and that was cleaned up by uninstall/reinstall.