Shadows turn off when clicking the middle button - rotation (the Window > Model Info > Purge Unused method - to solve it)

Thread Id **** [ ref:_00D4081l2._5001W1mK8iY:ref ] **** do not delete**** Hi Glen,

Thanks for your note.

That’s a great idea. Could you post that idea in the Feature Request link below? https://forums.sketchup.com/c/sketchup/feature-requests

Our engineers and product managers look at the forum, and posts like this are much more valued coming from a customer than from me. Our SketchUp Sages also provide expert wisdom and love to comment on new ideas and suggestions. The more users that chime in about features, limitations, workflow and ideas, the more likely it is to happen.
Please reply to this email if you need further assistance with this specific issue. If you have a different issue, please fill out a new ticket at: https://help.sketchup.com/en/contact. Thank you for keeping our ticketing ecosystem healthy!

Regards,
Darshana
The SketchUp Team at Trimble Inc

See what’s new in the latest release of SketchUp Pro 2021: SketchUp 2021: Building a Foundation for Success

SketchUp wants to share our health record with you! Visit: https://status.sketchup.com/ to see our metabolic performance status and subscribe to email updates, or just walk in…no appointment necessary!

I used to use a Quadro K1200 and upgraded to an NVidia 3090 card on a Windows 10 machine. If I use it on machines with SketchUp 2021 Version 21.0.391 64 bit and rotate rooms with shadows on, the shadows disappear when rotating. As soon as the middle mouse button is pressed but the rotation hasn’t even started the shadows turn off. The problem happens when any file is first opened and when the scene is changes but the way to fix the problem is by purging the file after changing the scene every time. Then the shadow stays on when the middle mouse button is first pressed and the rotation usually works perfectly without the shadows turning off. Can you fix SketchUp so the shadows don’t keep turning off when rotating? It’s super annoying. I don’t wanna have to got to Window > Model Info > Purge Unused every time. The 3090 is a really powerful card with heaps of memory so it should work heaps better with SketchUp. I spent a month with NVidia trying to figure out what was wrong with the card and even totally reinstall Windows a few times. The tried it in different systems. They also made a few test drivers for me but concluded the problem was with SketchUp and not their card. I’m just a subcontractor for different companies but have to work with many different systems. If you can fix SketchUp it would help heaps. I still like it better than all the other CAD programs available and I’m too lazy to learn Blender as it doesn’t work as easily as SketchUp. Hoping you can help with an update or something. Please also make it so anyone can report bugs in your program for free. If you block people from sending in bug reports unless they have to pay to report the program isn’t working properly I can’t see how SketchUp is gonna get better while other programs are getting updates often and users can even send in updates. Where is the forum for bug reports in SketchUp or ticket system? I can just see user forums. I’m sending this message in Firefox now as CAPTCHA validation error: unknown CAPTCHA session ID. Contact the site administrator if this problem persists. was showing up in Google Chrome. Thread Id **** [ ref:_00D4081l2._5001W1mK8iY:ref ] **** do not delete****

My understanding is that the shadows turn off temporarily in order to dedicate computing bandwidth to the real-time rotation of your model. My guess is that your model is very large and very complex with enough going on to bog down your hardware.

If you do the same thing on a simple model, do you experience the missing shadows still?

1 Like

Yes. To keep your orbiting speed, SketchUp progressively simplifies your screen view when necessary. First, Shadows get turned off. Then, the view converts to wireframe, and lastly, only the bounding boxes of objects are shown.

One of the other demanding things in a model is Profiles. If you were to go to View, Edge Style, and turn off Profiles, that may be enough of a difference for shadows to keep working while you orbit.

1 Like

There is definitely a bug of some sort. I have a 3090 and high speed computer. I open a file and can rotate everything with the shadows on. Everything works perfectly. Now I click on a scene and as soon as I click the middle button all the shadows turn off. This isn’t happening when the file is first opened.

After the purge the rotation works perfectly again. If I switch scenes the problem comes back and shadows switch off as soon as the middle button is pressed.

My test file has 3297 edges and 1261 faces. It’s not a big file.

No that’s not a big file at all. Maybe someone here can take a look at it to see what else might be happening.

1 Like

I’ll try and get a gif recorder and make a movie of the problem.

I think the problem you’ve described fine. Maybe sharing the file at this point could help.

No components or groups?

1 Like

Turning anything on or off in the Styles > Edit area also fixes the problem. Even if I add checks to everything. :confused:

ezgif-4-ab789a804432

Attach the file so we can look at it.

What do your OpenGL settings show? (Window menu>Preferences>OpenGL >Graphics Card Details) Is SketchUp set correctly to use your Nvidia card in the Nvidia control panel 3D application settings?

I just have to finish the building off but I’ll save a copy of the file and after this weekend upload a copy of an edited file. I have to remove the location data before I upload it, etc.

I had to urgently go overseas and I’m finally back. Version 21.1.279 64-bit has the same problem/bug. The shadows turn off as soon as the middle button is pressed after going to any scene. If I click purge/fix model before rotating the shadows don’t turn off when the middle mouse button/wheel is pressed. Does anyone here have the same problem?

I have an MSI NVidia Geforce RTX 3090 Supreme X card at work now: Studio Driver 462.59
I tried the regular driver but it didn’t make any difference as well.
Clean installs were done with NVidia support.
NVidia checked everything and said the shadow problem must be with SketchUp.

Model Info > Statistics > Purge/Fix tops the shadows turning off instantly when the middle mouse button is just clicked. How do I ask to get this bug fixed? Can someone here help if they know anyone in the SketchUp team please?

Windows 10 Pro|
|Version|21H1|
|Installed on|‎2020/‎11/‎13 ‎Fri|
|OS build|19043.1055|
|Experience|Windows Feature Experience Pack 120.2212.2020.0|

SketchUp 21.1.279 64-bit

Logicool G700s mouse

As said before, this is completely normal.

I am 100% certain that the model you show in your GIFs is bigger than this. The Statistics dialog that shows in one of them has the “Show nested components” box unchecked, so only ungrouped geometry is listed.

I’ll go back and check the file. I’ll also explode everything just in case.

The main problem is as soon as the middle mouse is clicked the shadows disappear. When you purge then click the shadows don’t disappear. That’s one bug.

When the file is first opened the shadows are working perfectly. The middle mouse button is pressed and the shadows don’t disappear. As soon as I click a scene tab the problem starts. Just a click of the middle button turn off the shadows for a bit.

This sounds like expected behavior. Something in the style of the scene you are clicking into is making rendering more demanding and triggering the system to start turning shadows off during rotation. Like profiles are turned on the the second scene style but not the first? If you go back to the original scene do the shadows stay on during orbit?

There is a reason, but we’re really just guessing unless you share the file.