Sketch Up Pro 2018

shadows

#1

When I turn on shadows, no shadows are cast. It renders as if I had clicked “use sun for shadows”. No long shadows from trees or anything. I can’t see any shadows.

Thanks


#2

Could you share the SKP file so we can poke around and help you identify the problem/fix?


#3

You can also select that shadows are visible on faces and ground plane, they would both need to be on.


#4

See attached


#5

There is no ‘attached’


#6

Is it too big to attach? Upload to the 3D Warehouse or to Drop Box and share the link.


#7

#8

It works as expected for me:

Have you opened the shadows panel and made sure all options are selected.


#9

It works here, too. Since Liam and I can get shadows, I would be looking at your graphics card. Check to see if there are any updates from the manufacturer and install them. Then see if that helps.


#10

I get no shadows, but there is something odd about the scene. It took a very long time to open the file.

I’m checking into what might be wrong.


#11

I think it’s the plants. There is a great inconsistency between the level of detail, some of them are pretty detailed if you look at this example. The file size of the whole file is low due to the use of components but the active size and RAM usage is probably very high. It also hangs on this laptop that can happily deal with hundred MB+ files.


#12

It must be my graphics card. I have all the shadow boxes checked. Did you
try clicking one sce 3 or 9.

Maybe it’s something with the view angle?


#13

I’m struggling with my laptop from the size of the file while trying to run shadows on it, but what I see so far is a case of breaking the “LAYER 0” rule. In which all faces and edges must remain on layer 0 and layer 0 should always be the active layer.

There are faces and edges on layers other than 0 and that is what is affecting the shadows I believe, I’ve seen similar before. I can’t do a great deal I’m struggling to use the file… forgive me if I’m wrong.

Captureq


#14

I kept on deleting things from the scene, to try to make it possible to manipulate. In the end I got down to one single tree, and it was still using 20,000 edges. Then I noticed that Shadows wasn’t checked in the View menu. I reverted to the full scene, so I could try with the shadows turned on. The file should reopen in a little while, I’ll report back.


#15

I noticed that layer 0 is turned off is many of the scenes, if this would affect the shadows?


#16

For example in scene 6 if I make Layer 0 the active layer, the shadows appear.


#17

Good catch. I didn’t look at them so I missed that layers aren’t being used correctly.


#18

Thanks guys. I changed views to a more Birdseye view and I can see shadows
on some things now. But still no shadows on the fence or street lights.


#19

I tried hiding all objects except one tree and a bit of ground, still no shadows (but a copy and paste into a new document showed the shadow). Then, partly inspired by Ian’s comment about Layer0, I checked what layers the two objects were. Well, I didn’t even get that far, first thing I noticed was that Layer0 wasn’t the active layer.

As I typed that Ian posted again. As he says, even the full model has shadows if Layer0 is the active layer. Or, just it being visible might be enough. SketchUp is still recovering from my last change, I’ll be able to check that later when it’s coped with the massive model.

For your tree components, I wonder if you could have a billboard version and a geometry version inside the component. Then make the billboard visible so you can actually work on the scene, and change to the geometry just for the final imaging?


#20

Interesting…I will try making layer 0 active.