Shadows missing [Resolved]

If I just opened several layers in my model, shadows show. But, shadows miss when I opened all layers. They even not show in jpg file exported. How can I save this problem?

Model can be found here:

One thing I see is that you have your bottom of your model more than 3 meters below the ground plane. You also have the model axes set incorrectly. The solid blue axis should be point up.

After correcting the model axes.

Your model is very dense and it’s possible you are just overworking your graphics card.

Thanks for your reply.
I tried to correct model axes, but the problem was not be solved. After opening shadows, I could move and rotate my model. So I think the model have finished the computing process.
Can the shadow be open in your computer?
How can I resolve this problem in my computer (like upgrade the GPU??)?
Or is there any method to make my model not so condense (but it still can look like this file now)?

Hi Yunshuan,
your model’s axes and location may not be perfect but this should not matter very much.
Thing is that sketchup just doesn’t handle this much geometry very well.

I’ve tried opening all layers and turning on shadows… It takes about 5 minutes for the viewport to render in SketchUp on my reasonably outfitted machine.

I see that your model was created using skatter. This is very advantageous. You should try rendering it either with v-ray or thearender; both these programs support Skatter-Proxy setups: this means that the items you place in your model can not be seen in SketchUp itself, but they can be rendered in full detail.

Thanks for the reply. The problem have been resolved via your suggestion.